at91dataflashboot: add a patch step
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 17 Mar 2010 08:15:26 +0000 (09:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Jun 2010 11:38:48 +0000 (13:38 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/at91dataflashboot/at91dataflashboot.mk

index dcbe1ef030b47dd01b5e1de7319a045d1b8a779a..d11f842d817c11dd593617e0f3e5355b2087a811 100644 (file)
@@ -18,7 +18,11 @@ $(DATAFLASHBOOT_DIR)/.unpacked: $(DL_DIR)/$(DATAFLASHBOOT_SOURCE)
        $(BZCAT) $(DL_DIR)/$(DATAFLASHBOOT_SOURCE) | tar $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
        touch $(DATAFLASHBOOT_DIR)/.unpacked
 
-$(DATAFLASHBOOT_DIR)/$(DATAFLASHBOOT_BINARY): $(DATAFLASHBOOT_DIR)/.unpacked
+$(DATAFLASHBOOT_DIR)/.patched: $(DATAFLASHBOOT_DIR)/.unpacked
+       toolchain/patch-kernel.sh $(@D) boot/at91dataflashboot \
+               at91dataflashboot-$(DATAFLASHBOOT_VERSION)-\*.patch
+
+$(DATAFLASHBOOT_DIR)/$(DATAFLASHBOOT_BINARY): $(DATAFLASHBOOT_DIR)/.patched
        ls $(DATAFLASHBOOT_DIR)/.unpacked
        make -C $(DATAFLASHBOOT_DIR) CROSS_COMPILE=$(TARGET_CROSS)