qt: fix mysql dependency and disable unavailable sql drivers
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jul 2010 21:55:30 +0000 (23:55 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jul 2010 21:55:30 +0000 (23:55 +0200)
We don't have the needed dependencies in BR for most of the SQL drivers,
so mark those options as broken.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/Config.sql.in
package/qt/qt.mk

index 2ce8d7964c889ab1fa6573e9907b2cf64d694b4c..b982fdb4da8a6994ecfc79dedfe4eb7f674a7341 100644 (file)
@@ -6,24 +6,30 @@ menuconfig BR2_PACKAGE_QT_SQL_MODULE
 if BR2_PACKAGE_QT_SQL_MODULE
 config BR2_PACKAGE_QT_MYSQL
        bool "MySQL Driver"
+       select BR2_PACKAGE_MYSQL_CLIENT
+       select BR2_PACKAGE_NCURSES
+       select BR2_PACKAGE_READLINE
        help
          Build MySQL driver
          If unsure, say n.
 
 config BR2_PACKAGE_QT_IBASE
        bool "iBase Driver"
+       depends on BROKEN # libfbclient not in BR
        help
          Build iBase driver
          If unsure, say n.
 
 config BR2_PACKAGE_QT_ODBC
        bool "ODBC Driver"
+       depends on BROKEN # libodbc not in BR
        help
          Build ODBC driver
          If unsure, say n.
 
 config BR2_PACKAGE_QT_PSQL
        bool "PostgreSQL Driver"
+       depends on BROKEN # libpgsql not in BR
        help
          Build PostgreSQL driver
          If unsure, say n.
@@ -36,6 +42,7 @@ config BR2_PACKAGE_QT_SQLITE
 
 config BR2_PACKAGE_QT_SQLITE2
        bool "SQLite 2 Driver"
+       depends on BROKEN # sqlite2 not in BR
        help
          Build SQLite 2 driver
          If unsure, say n.
index dd43ae02b4cede7bdeea885191295e8d4a971850..864e79bb60a9812b1b5707ea709f05b0d11da96b 100644 (file)
@@ -273,7 +273,9 @@ ifeq ($(BR2_PACKAGE_QT_IBASE),y)
 QT_CONFIGURE+= -qt-sql-ibase
 endif
 ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
-QT_CONFIGURE+= -qt-sql-mysql
+QT_CONFIGURE+= -qt-sql-mysql -I $(STAGING_DIR)/usr/include/mysql -L $(STAGING_DIR)/usr/lib/mysql
+
+QT_DEP_LIBS+=mysql_client
 endif
 ifeq ($(BR2_PACKAGE_QT_ODBC),y)
 QT_CONFIGURE+= -qt-sql-odbc