Makefile: add missing targets to noconfig_targets and nobuild_targets
authorRahul Jain <Rahul.Jain@imgtec.com>
Tue, 15 Nov 2016 11:03:20 +0000 (16:33 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Nov 2016 21:43:23 +0000 (22:43 +0100)
currently some buildroot targets fails (list-defconfigs,
graph-build, etc), if there is an issue with configuration.
For example, enabling uboot package without providing custom
version name results in failing of various targets.

Signed-off-by: Rahul Jain <Rahul.Jain@imgtec.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Thomas: as suggested by Arnout, added printvars and savedefconfig to
nobuild_targets.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 6cf5f1ce1eb44885c17ba82cc5d61eb229e2f363..eff814b8c6f13c63128bb1c16f75b47599299766 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -126,7 +126,8 @@ export BR2_VERSION_FULL := $(BR2_VERSION)$(shell $(TOPDIR)/support/scripts/setlo
 noconfig_targets := menuconfig nconfig gconfig xconfig config oldconfig randconfig \
        defconfig %_defconfig allyesconfig allnoconfig silentoldconfig release \
        randpackageconfig allyespackageconfig allnopackageconfig \
-       print-version olddefconfig distclean
+       print-version olddefconfig distclean manual manual-html manual-split-html \
+       manual-pdf manual-text manual-epub
 
 # Some global targets do not trigger a build, but are used to collect
 # metadata, or do various checks. When such targets are triggered,
@@ -137,9 +138,12 @@ noconfig_targets := menuconfig nconfig gconfig xconfig config oldconfig randconf
 # We're building in two situations: when MAKECMDGOALS is empty
 # (default target is to build), or when MAKECMDGOALS contains
 # something else than one of the nobuild_targets.
-nobuild_targets := source source-check \
-       legal-info external-deps _external-deps \
-       clean distclean help
+nobuild_targets := source %-source source-check \
+       legal-info %-legal-info external-deps _external-deps \
+       clean distclean help show-targets graph-depends \
+       %-graph-depends %-show-depends %-show-version \
+       graph-build graph-size list-defconfigs \
+       savedefconfig printvars
 ifeq ($(MAKECMDGOALS),)
 BR_BUILDING = y
 else ifneq ($(filter-out $(nobuild_targets),$(MAKECMDGOALS)),)