package/e2fsprogs: disable use of magic.h
authorMax Filippov <jcmvbkbc@gmail.com>
Wed, 16 Nov 2016 23:26:01 +0000 (15:26 -0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Nov 2016 09:34:26 +0000 (10:34 +0100)
RHEL 5.x does have magic.h, but it does not define all expected symbols.
In particular, the NO_CHECK symbols were only added in file 4.20 and RHEL
5.x is using 4.17. Don't use magic.h and libmagic when building host
package.

Suggested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/e2fsprogs/e2fsprogs.mk

index 022ba5283a9ed2472ba7c32b4b4a4bfe8dc66d2c..b6e79d246b758a64f229192f8be4bec77b4f3e7e 100644 (file)
@@ -51,6 +51,12 @@ endif
 # for util/subst.c to build properly.
 E2FSPROGS_CONF_ENV += BUILD_CFLAGS="-DHAVE_SYS_STAT_H"
 
+# Disable use of the host magic.h, as on older hosts (e.g. RHEL 5)
+# it doesn't provide definitions expected by e2fsprogs support lib.
+HOST_E2FSPROGS_CONF_ENV += \
+       ac_cv_header_magic_h=no \
+       ac_cv_lib_magic_magic_file=no
+
 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
 # util-linux libuuid pulls in libintl if needed, so ensure we also
 # link against it, otherwise static linking fails