package/rsyslog: install default service file
authorSam Voss <sam.voss@rockwellcollins.com>
Wed, 14 Apr 2021 21:09:27 +0000 (16:09 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Apr 2021 21:21:04 +0000 (23:21 +0200)
As of v8.2008 rsyslog no longer provides a default service file, and now
suggests using the platform suggested defaults. For Buildroot, install
the Debian service file which has been added in the same version,
however is not included in the official release.

Upstream commit which adds this service file:
https://github.com/rsyslog/rsyslog/commit/cfd07503ba055100a84d75d1a78a5c6cceb9fdab

Signed-off-by: Sam Voss <sam.voss@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rsyslog/rsyslog.mk
package/rsyslog/rsyslog.service [new file with mode: 0644]

index 99e80ae268b310670606cf9085339b249634348d..1aa81b8eac6f72e97b49bf3f302465b904cd3b48 100644 (file)
@@ -101,6 +101,11 @@ RSYSLOG_CONF_OPTS += \
        --disable-omjournal
 endif
 
+define RSYSLOG_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -m 0755 -D package/rsyslog/rsyslog.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/rsyslog.service
+endef
+
 define RSYSLOG_INSTALL_INIT_SYSV
        $(INSTALL) -m 0755 -D package/rsyslog/S01rsyslogd \
                $(TARGET_DIR)/etc/init.d/S01rsyslogd
diff --git a/package/rsyslog/rsyslog.service b/package/rsyslog/rsyslog.service
new file mode 100644 (file)
index 0000000..40c7c22
--- /dev/null
@@ -0,0 +1,19 @@
+[Unit]
+Description=System Logging Service
+Requires=syslog.socket
+Documentation=man:rsyslogd(8)
+Documentation=https://www.rsyslog.com/doc/
+
+[Service]
+Type=notify
+ExecStart=/usr/sbin/rsyslogd -n -iNONE
+StandardOutput=null
+Restart=on-failure
+
+# Increase the default a bit in order to allow many simultaneous
+# files to be monitored, we might need a lot of fds.
+LimitNOFILE=16384
+
+[Install]
+WantedBy=multi-user.target
+Alias=syslog.service