openssl: fix compilation for i386
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 14 Mar 2011 17:33:48 +0000 (14:33 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 1 Apr 2011 19:56:21 +0000 (21:56 +0200)
Closes #3445.

OpenSSL emits bswap instructions when building for i386 targets which
unfortunately is only available on 486+ class processors.
Since the normal workaround is detected at build time and we are cross
compiling we need to specify this.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/openssl/openssl.mk

diff --git a/CHANGES b/CHANGES
index 09088041ea9f7e3bd37ce078f45497cdf024fac3..c22d0b6ca8c76a3d1ddde90af9d2be75d2bcc7d5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -4,12 +4,13 @@
        avahi, busybox, dnsmasq, dropbear, ethtool, fakeroot, ffmpeg,
        file, gnuconfig, gst-ffmpeg, gst-plugins-good, icu,
        imagemagick, libdnet, libpng, libxml2, libxslt, makedevs,
-       mpg123, mtd-utils, ncurses, netsnmp, pkg-config, qt, samba,
-       socat, squashfs, webkit, xerces, xlib_xtrans, xorg-server,
-       xterm, xz
+       mpg123, mtd-utils, ncurses, netsnmp, openssl, pkg-config, qt,
+       samba, socat, squashfs, webkit, xerces, xlib_xtrans,
+       xorg-server, xterm, xz
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #3445: Not working openssl-10.0.0d on 386sx
        #3451: fakeroot package: wrong FAKEROOT_SITE variable
        #3457: alsamixergui: broken URL
        #3475: Calling sync on large filesystems when not always necessary
index 7bf347ad876c2bcdf65206a3426115067cd56924..0163ef84705673b92c10f4aaabb5108ee8311c57 100644 (file)
@@ -39,6 +39,11 @@ ifeq ($(ARCH),x86_64)
        OPENSSL_TARGET_ARCH = x86_64
 endif
 
+# Workaround for bug #3445
+ifeq ($(BR2_x86_i386),y)
+       OPENSSL_TARGET_ARCH = generic32 386
+endif
+
 define OPENSSL_CONFIGURE_CMDS
        (cd $(@D); \
                $(TARGET_CONFIGURE_ARGS) \