- remove the '"install uClibc headers in the target filesystem" without a native...
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 31 Jan 2007 10:10:06 +0000 (10:10 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 31 Jan 2007 10:10:06 +0000 (10:10 -0000)
package/Config.in
toolchain/Makefile.in
toolchain/gcc/Config.in.2
toolchain/uClibc/Config.in.2 [deleted file]
toolchain/uClibc/Makefile.in [deleted file]
toolchain/uClibc/uclibc.mk

index 06f45fe5e116d7a2add97d370670b18224d838ed..ca2221f5bd900c6e887cf9a4c61af9ed2d1602db 100644 (file)
@@ -32,7 +32,6 @@ source "package/tar/Config.in"
 endif
 
 comment "Other development stuff"
-source "toolchain/uClibc/Config.in.2"
 source "package/autoconf/Config.in"
 source "package/automake/Config.in"
 source "package/bison/Config.in"
index 45ee14a3baa63763a0c30cfaec6e67ddcb20d4ef..1a2c0f26f5b9b4ef51731bade5993c3772ad0a9f 100644 (file)
@@ -16,5 +16,3 @@ OPTIMIZE_FOR_CPU=$(ARCH)
 
 # gcc has a bunch of needed stuff....
 include toolchain/gcc/Makefile.in
-
-include toolchain/uClibc/Makefile.in
index d83502ba1656c2154cad70cfcbb9223378d15623..bb97286c1df4e8054556449cf2047dd8e63a3ccb 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_GCC_TARGET
        bool "native toolchain in the target filesystem"
        default n
-       select BR2_PACKAGE_UCLIBC_TARGET_HEADERS
        help
          If you want the target system to be able to run 
          binutils/gcc and compile native code, say Y here.
diff --git a/toolchain/uClibc/Config.in.2 b/toolchain/uClibc/Config.in.2
deleted file mode 100644 (file)
index 90a065e..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-config BR2_PACKAGE_UCLIBC_TARGET_HEADERS
-       bool "install uClibc headers in the target filesystem"
-       default n
-       help
-         Install the uClibc headers and kernel-headers in the
-         target filesystem.
diff --git a/toolchain/uClibc/Makefile.in b/toolchain/uClibc/Makefile.in
deleted file mode 100644 (file)
index f83651e..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-
-ifeq ($(strip $(BR2_PACKAGE_UCLIBC_TARGET_HEADERS)),y)
-TARGETS+=uclibc_target_headers
-endif
index b6dea19204e3eb9af65c0c773c73dd808314b839..0fcd64c2d69b495b7c7248daa2caac360023a595 100644 (file)
@@ -323,32 +323,6 @@ $(TARGET_DIR)/usr/lib/libc.a: $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libc.a
        fi;
        touch -c $(TARGET_DIR)/usr/lib/libc.a
 
-$(TARGET_DIR)/usr/include/libc-internal.h: $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libc.a
-       $(MAKE1) -C $(UCLIBC_DIR) \
-               PREFIX=$(TARGET_DIR) \
-               DEVEL_PREFIX=/usr/ \
-               RUNTIME_PREFIX=/ \
-               install_headers
-       # Install the kernel headers to the target dir if necessary
-       if [ ! -f $(TARGET_DIR)/usr/include/linux/version.h ] ; then \
-               cp -pLR $(LINUX_HEADERS_DIR)/include/asm $(TARGET_DIR)/usr/include/ ; \
-               cp -pLR $(LINUX_HEADERS_DIR)/include/linux $(TARGET_DIR)/usr/include/ ; \
-               if [ -d $(LINUX_HEADERS_DIR)/include/asm-generic ] ; then \
-                       cp -pLR $(LINUX_HEADERS_DIR)/include/asm-generic \
-                               $(TARGET_DIR)/usr/include/ ; \
-               fi; \
-       fi;
-
-ifeq ($(BR2_PACKAGE_UCLIBC_TARGET_HEADERS),y)
-uclibc_target_headers: $(TARGET_DIR)/usr/include/libc-internal.h
-uclibc_target_headers-clean:
-       rm -rf $(TARGET_DIR)/usr/include
-uclibc_target_headers-dirclean:
-       rm -rf $(TARGET_DIR)/usr/include
-else
-uclibc_target_headers: ;
-endif
-
 uclibc_target: gcc uclibc $(TARGET_DIR)/usr/lib/libc.a $(TARGET_DIR)/usr/bin/ldd
 
 uclibc_target-clean: