iptables: fix build after linux-headers changes
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 6 Jul 2013 15:18:50 +0000 (17:18 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 7 Jul 2013 19:19:45 +0000 (21:19 +0200)
As reported by 'scanf' on IRC, the iptables now fails to build because
of a missing <asm/cache.h> header in the kernel headers. The package
directly uses $(LINUX_HEADERS_DIR), which is not correct: this is the
source directory of the kernel, not where they are installed, and in
addition, this directory is empty/does not exist when using external
toolchains.

Instead, we use $(STAGING_DIR)/usr, which contains the kernel headers,
as part of the toolchain headers.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/iptables/iptables.mk

index cfb227ad91f91066231300232e12f875d9a2f135..f548cb9f4b012c1f5299b1477a01fdaafa41be40 100644 (file)
@@ -12,7 +12,7 @@ IPTABLES_DEPENDENCIES = host-pkgconf
 IPTABLES_LICENSE = GPLv2
 IPTABLES_LICENSE_FILES = COPYING
 
-IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(LINUX_HEADERS_DIR)
+IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(STAGING_DIR)/usr
 
 define IPTABLES_TARGET_SYMLINK_CREATE
        ln -sf xtables-multi $(TARGET_DIR)/usr/sbin/iptables