u-boot: add version 2012.07
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 4 Sep 2012 03:55:23 +0000 (03:55 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Sep 2012 20:26:46 +0000 (22:26 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/uboot/Config.in
package/uboot-tools/uboot-tools-2012.04.01-drop-configh-from-tools.patch [deleted file]
package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch [deleted file]
package/uboot-tools/uboot-tools-2012.07-drop-configh-from-tools.patch [new file with mode: 0644]
package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch [new file with mode: 0644]
package/uboot-tools/uboot-tools.mk

index 900fac7fc0b1f46456c5252234fb3d8650c2ce6d..7f3cae00e02def6a8ae7e5e776de7c9dc417715b 100644 (file)
@@ -12,10 +12,13 @@ config BR2_TARGET_UBOOT_BOARDNAME
 
 choice
        prompt "U-Boot Version"
-       default BR2_TARGET_UBOOT_2012_04
+       default BR2_TARGET_UBOOT_2012_07
        help
          Select the specific U-Boot version you want to use
 
+config BR2_TARGET_UBOOT_2012_07
+       bool "2012.07"
+
 config BR2_TARGET_UBOOT_2012_04
        bool "2012.04.01"
 
@@ -50,6 +53,7 @@ endif
 
 config BR2_TARGET_UBOOT_VERSION
        string
+       default "2012.07"       if BR2_TARGET_UBOOT_2012_07
        default "2012.04.01"    if BR2_TARGET_UBOOT_2012_04
        default "2011.12"       if BR2_TARGET_UBOOT_2011_12
        default "2011.09"       if BR2_TARGET_UBOOT_2011_09
diff --git a/package/uboot-tools/uboot-tools-2012.04.01-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-2012.04.01-drop-configh-from-tools.patch
deleted file mode 100644 (file)
index 2b3a0e5..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 39857718f4df9b40a7acf38b73140fd86c628ef0 Mon Sep 17 00:00:00 2001
-From: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Date: Mon, 30 Apr 2012 09:07:38 -0300
-Subject: [PATCH] fw_env: allow it to build without a config
-
-We need to build u-boot tools without a board configuration for the
-target packages.
-fw_env just uses config.h to define the default environment of the
-created image, so it really isn't mandatory.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
- tools/env/fw_env.c |    2 --
- 1 files changed, 0 insertions(+), 2 deletions(-)
-
-diff --git a/tools/env/fw_env.c b/tools/env/fw_env.c
-index e292d2b..2bb061a 100644
---- a/tools/env/fw_env.c
-+++ b/tools/env/fw_env.c
-@@ -45,8 +45,6 @@
- #include "fw_env.h"
--#include <config.h>
--
- #define WHITESPACE(c) ((c == '\t') || (c == ' '))
- #define min(x, y) ({                          \
--- 
-1.7.3.4
-
diff --git a/package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-2012.04.01-hostcflags-override-fix.patch
deleted file mode 100644 (file)
index 0202eda..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-[PATCH] Fix tools build with custom HOSTCFLAGS
-
-We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
-overridden on the cmdline.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- config.mk |    6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-Index: u-boot-2011.03/config.mk
-===================================================================
---- u-boot-2011.03.orig/config.mk
-+++ u-boot-2011.03/config.mk
-@@ -46,10 +46,12 @@
- #########################################################################
--HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
--                $(HOSTCPPFLAGS)
-+HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
- HOSTSTRIP     = strip
-+# append CPPFLAGS even if CFLAGS has been overridden on cmdline
-+override HOSTCFLAGS += $(HOSTCPPFLAGS)
-+
- #
- # Mac OS X / Darwin's C preprocessor is Apple specific.  It
- # generates numerous errors and warnings.  We want to bypass it
diff --git a/package/uboot-tools/uboot-tools-2012.07-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-2012.07-drop-configh-from-tools.patch
new file mode 100644 (file)
index 0000000..2b3a0e5
--- /dev/null
@@ -0,0 +1,31 @@
+From 39857718f4df9b40a7acf38b73140fd86c628ef0 Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Mon, 30 Apr 2012 09:07:38 -0300
+Subject: [PATCH] fw_env: allow it to build without a config
+
+We need to build u-boot tools without a board configuration for the
+target packages.
+fw_env just uses config.h to define the default environment of the
+created image, so it really isn't mandatory.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+ tools/env/fw_env.c |    2 --
+ 1 files changed, 0 insertions(+), 2 deletions(-)
+
+diff --git a/tools/env/fw_env.c b/tools/env/fw_env.c
+index e292d2b..2bb061a 100644
+--- a/tools/env/fw_env.c
++++ b/tools/env/fw_env.c
+@@ -45,8 +45,6 @@
+ #include "fw_env.h"
+-#include <config.h>
+-
+ #define WHITESPACE(c) ((c == '\t') || (c == ' '))
+ #define min(x, y) ({                          \
+-- 
+1.7.3.4
+
diff --git a/package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch b/package/uboot-tools/uboot-tools-2012.07-hostcflags-override-fix.patch
new file mode 100644 (file)
index 0000000..0202eda
--- /dev/null
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk |    6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+ #########################################################################
+-HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+-                $(HOSTCPPFLAGS)
++HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP     = strip
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific.  It
+ # generates numerous errors and warnings.  We want to bypass it
index 53764f76f00bd4a3fbdf3839df3fb1a4ff4a7178..7628b77b8b0f3b53a9bc16622e2b095c61856174 100644 (file)
@@ -1,4 +1,4 @@
-UBOOT_TOOLS_VERSION = 2012.04.01
+UBOOT_TOOLS_VERSION = 2012.07
 UBOOT_TOOLS_SOURCE  = u-boot-$(UBOOT_TOOLS_VERSION).tar.bz2
 UBOOT_TOOLS_SITE    = ftp://ftp.denx.de/pub/u-boot