mysql: add mysql init script
authorMarcelo Gutiérrez(UTN/FRH) <kuyurix@gmail.com>
Tue, 4 Mar 2014 14:50:02 +0000 (14:50 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Jul 2014 21:52:52 +0000 (23:52 +0200)
[Thomas: explicitly specify the path to the PID file, and also on the
first boot, generate the mandatory MySQL system tables so that the
MySQL daemon actually starts properly.]

Signed-off-by: Marcelo Gutiérrez <kuyurix@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
merge init script

package/mysql/S97mysqld [new file with mode: 0644]
package/mysql/mysql.mk

diff --git a/package/mysql/S97mysqld b/package/mysql/S97mysqld
new file mode 100644 (file)
index 0000000..6f25403
--- /dev/null
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+case "$1" in
+       start)
+               if [ ! -d /var/mysql/mysql ] ; then
+                       echo "Creating MySQL system tables..."
+                       mysql_install_db --user=mysql --ldata=/var/mysql
+               fi
+
+               # We don't use start-stop-daemon because mysqld has
+               # its own wrapper script.
+               echo -n "Starting mysql..."
+               /usr/bin/mysqld_safe --pid-file=/var/run/mysqld.pid &
+               echo "done."
+               ;;
+       stop)
+               echo -n "Stopping mysql..."
+               if test -f /var/run/mysqld.pid ; then
+                       kill `cat /var/run/mysqld.pid`
+               fi
+               echo "done."
+               ;;
+       restart)
+               $0 stop
+               $0 start
+               ;;
+       *)
+               echo "Usage: /etc/init.d/mysqld {start|stop|restart}"
+               ;;
+esac
index 44dcb7e14ff1aec0f8f999dc1bd0bacbe55447f7..fec8b03f832ca41d10da2910e4428e889c94f556 100644 (file)
@@ -99,6 +99,11 @@ endef
 
 MYSQL_POST_INSTALL_TARGET_HOOKS += MYSQL_ADD_FOLDER
 
+define MYSQL_INSTALL_INIT_SYSV
+       $(INSTALL) -D -m 0755 package/mysql/S97mysqld \
+               $(TARGET_DIR)/etc/init.d/S97mysqld
+endef
+
 else
 MYSQL_CONF_OPT += \
        --without-server