nginx: group the external modules enabling logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 22:34:17 +0000 (23:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 22:34:17 +0000 (23:34 +0100)
This commit moves the logic that allows to enable the naxsi external
module below the "external modules" comment, which was already used for
the upload and dav-ext modules.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nginx/nginx.mk

index 79cc4ed3e3f7e6dde696fb5c9c4a15e83dac44ff..b7384a26e824635df6a471a31d27f8880b061a6b 100644 (file)
@@ -156,11 +156,6 @@ else
 NGINX_CONF_OPTS += --without-http_gzip_module
 endif
 
-ifeq ($(BR2_PACKAGE_NGINX_NAXSI),y)
-NGINX_DEPENDENCIES += nginx-naxsi
-NGINX_CONF_OPTS += --add-module=$(NGINX_NAXSI_DIR)/naxsi_src
-endif
-
 ifeq ($(BR2_PACKAGE_NGINX_HTTP_REWRITE_MODULE),y)
 NGINX_DEPENDENCIES += pcre
 else
@@ -250,6 +245,11 @@ NGINX_CONF_OPTS += --add-module=$(NGINX_DAV_EXT_DIR)
 NGINX_DEPENDENCIES += nginx-dav-ext
 endif
 
+ifeq ($(BR2_PACKAGE_NGINX_NAXSI),y)
+NGINX_DEPENDENCIES += nginx-naxsi
+NGINX_CONF_OPTS += --add-module=$(NGINX_NAXSI_DIR)/naxsi_src
+endif
+
 # Debug logging
 NGINX_CONF_OPTS += $(if $(BR2_PACKAGE_NGINX_DEBUG),--with-debug)