package/python: add optional support for lib2to3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 22 Feb 2020 18:54:59 +0000 (19:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Mar 2020 15:07:45 +0000 (16:07 +0100)
Kodi is in transition to support python3 instead of python2:
https://kodi.wiki/view/General_information_about_migration_to_Python_3

"For Kodi 18 (Leia), only addons that are compatible with both Python 2
 and 3 will be accepted to the official addon repository."

Some of these addons depend on the Kodi addon script.module.future to
provide support for both python versions.

The script.module.future addon contains python-future:
https://kodi.wiki/view/General_information_about_migration_to_Python_3#Future
which in turn needs lib2to3 to be included in the target build of
python2: http://python-future.org/automatic_conversion.html

Kodi addons depending on the script.module.future addon are crashing on
buildroot due to lib2to3 missing in the build.

LibreELEC added lib2to3 to python2 to fix the problem:
https://forum.libreelec.tv/thread/21239-lib2to3-pgen2-parse-missing/
https://github.com/LibreELEC/LibreELEC.tv/pull/4147

This patch provides the Config.in option to be used by Kodi.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python/Config.in
package/python/python.mk

index a7f16450e3b46fe3307dd8c93ee7f002ef078c0f..bded00c9e84cafc14c93d462f8f93b6ff33209e7 100644 (file)
@@ -39,6 +39,11 @@ menu "core python modules"
 
 comment "The following modules are unusual or require extra libraries"
 
+config BR2_PACKAGE_PYTHON_2TO3
+       bool "2to3 module"
+       help
+         code translation from python 2 to 3
+
 config BR2_PACKAGE_PYTHON_BZIP2
        bool "bzip2 module"
        select BR2_PACKAGE_BZIP2
index 1c393b255d10a218af231edee8a9c65c0a2c1814..f9d5619612f79fd9835876bd6718bf39a5f375df 100644 (file)
@@ -118,6 +118,12 @@ HOST_PYTHON_CONF_OPTS += --enable-unicode=ucs4
 PYTHON_CONF_OPTS += --enable-unicode=ucs4
 endif
 
+ifeq ($(BR2_PACKAGE_PYTHON_2TO3),y)
+PYTHON_CONF_OPTS += --enable-lib2to3
+else
+PYTHON_CONF_OPTS += --disable-lib2to3
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON_BZIP2),y)
 PYTHON_DEPENDENCIES += bzip2
 else
@@ -165,7 +171,6 @@ PYTHON_CONF_OPTS += \
        --with-system-ffi \
        --disable-pydoc \
        --disable-test-modules \
-       --disable-lib2to3 \
        --disable-gdbm \
        --disable-tk \
        --disable-nis \