host-mtools: Fix build failure introduced by libiconv dependency
authorBernd Kuhls <berndkuhls@hotmail.com>
Mon, 24 Mar 2014 19:29:45 +0000 (20:29 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 24 Mar 2014 20:15:30 +0000 (21:15 +0100)
Fixes http://autobuild.buildroot.net/results/8ff/8ff7fc94cc3e54f5608f7b4d2e6ccba5fd8e4177/

Also disable parallel make because "make install" is broken, see
http://lists.openembedded.org/pipermail/openembedded-commits/2011-October/134396.html

Signed-off-by: Bernd Kuhls <berndkuhls@hotmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mtools/mtools.mk

index 864932507e28a76dde7960f774c902d49591aa55..9dc72f3b86d7d7b2297dac9503a44ad355d74813 100644 (file)
@@ -16,7 +16,12 @@ MTOOLS_CONF_OPT = --without-x
 ifeq ($(BR2_PACKAGE_LIBICONV),y)
 MTOOLS_DEPENDENCIES += libiconv
 MTOOLS_CONF_ENV += LIBS=-liconv
+# We have no host dependencies
+HOST_MTOOLS_DEPENDENCIES =
 endif
 
+# Package does not build in parallel due to improper make rules
+MTOOLS_MAKE = $(MAKE1)
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))