pkg-generic: take into account <pkg>_EXTRA_DOWNLOADS to display "Downloading" message
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Mar 2015 17:33:17 +0000 (19:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 30 Mar 2015 21:38:49 +0000 (23:38 +0200)
The .stamp_downloaded target displays the "Downloading" message even
if there is really something to download. However, this logic only
checks for <pkg>_SOURCE and <pkg>_PATCH: it does not check if
something needs to be downloaded in <pkg>_EXTRA_DOWNLOADS.

This commit fixes that, which makes sure that the "Downloading"
message is displayed if one of the items in <pkg>_EXTRA_DOWNLOADS has
not yet been downloaded.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/pkg-generic.mk

index b44d476379b1297a9666cb929d7ac5beed57bc79..003fd693d619514593bbfdef2a0ab7668b95c391 100644 (file)
@@ -76,7 +76,7 @@ ifeq ($(DL_MODE),DOWNLOAD)
        $(Q)if test ! -e $(DL_DIR)/$($(PKG)_SOURCE); then \
                $(call MESSAGE,"Downloading") ; \
        else \
-               for p in $($(PKG)_PATCH) ; do \
+               for p in $($(PKG)_PATCH) $($(PKG)_EXTRA_DOWNLOADS) ; do \
                        if test ! -e $(DL_DIR)/`basename $$p` ; then \
                                $(call MESSAGE,"Downloading") ; \
                                break ; \