package/nginx: add stream ssl preread module
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 20 Sep 2020 08:13:53 +0000 (10:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 20 Sep 2020 13:31:42 +0000 (15:31 +0200)
stream ssl preread is available since version 1.11.5 and
https://github.com/nginx/nginx/commit/5a7afb1b0d3f74d0ff96d4d9c519c26deb0fde39

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 15e63f4a76abfcd086beb6d673fefc0ee7a2ceb7..6ae790a949cba9a876ad2fa7ef24e35858cbe2e5 100644 (file)
@@ -351,6 +351,11 @@ config BR2_PACKAGE_NGINX_STREAM_GEOIP_MODULE
        help
          Enable ngx_stream_geoip_module
 
+config BR2_PACKAGE_NGINX_STREAM_SSL_PREREAD_MODULE
+       bool "ngx_stream_ssl_preread_module"
+       help
+         Enable ngx_stream_ssl_preread_module
+
 config BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE
        bool "ngx_stream_limit_conn_module"
        default y
index 06fc49d24693539c217c019ae580f3c392fbd170..6ecd6a9a803c6f4f7619543c9e3cc056de890031 100644 (file)
@@ -239,6 +239,10 @@ NGINX_DEPENDENCIES += geoip
 NGINX_CONF_OPTS += --with-stream_geoip_module
 endif
 
+ifeq ($(BR2_PACKAGE_NGINX_STREAM_SSL_PREREAD_MODULE),y)
+NGINX_CONF_OPTS += --with-stream_ssl_preread_module
+endif
+
 NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE),,--without-stream_limit_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE),,--without-stream_access_module) \