libffi: fix mips build failures
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 28 Dec 2012 05:35:39 +0000 (05:35 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Dec 2012 15:55:09 +0000 (16:55 +0100)
Fixes
http://autobuild.buildroot.net/results/c4056ed2b969b900f7654e651e0e4cc2e8998e02

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libffi/libffi.mk

index 75705835efe9a429b756e38cb0d7a9d8547042c8..64b3eb41206c936fac8bbed9884c71dc9a74da2d 100644 (file)
@@ -8,9 +8,14 @@ LIBFFI_VERSION = 3.0.11
 LIBFFI_SITE    = ftp://sources.redhat.com/pub/libffi/
 LIBFFI_LICENSE = MIT
 LIBFFI_LICENSE_FILES = LICENSE
-
 LIBFFI_INSTALL_STAGING = YES
 
+# Newer CS MIPS toolchains use a different (compact) eh_frame format
+# libffi don't like them, just switch to the older format
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201209)$(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
+LIBFFI_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -mno-compact-eh"
+endif
+
 # Move the headers to the usual location, and adjust the .pc file
 # accordingly
 define LIBFFI_MOVE_STAGING_HEADERS