boot/syslinux: renumber patches
authorArnout Vandecappelle <arnout@mind.be>
Tue, 15 Aug 2017 22:45:45 +0000 (00:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Aug 2017 20:53:59 +0000 (22:53 +0200)
Also the last two are regenerated, their context has changed due to
the patches that have been removed earlier.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
12 files changed:
boot/syslinux/0003-memdisk-Force-ld-output-format-to-32-bits.patch [new file with mode: 0644]
boot/syslinux/0004-memdisk-Force-ld-output-format-to-32-bits.patch [deleted file]
boot/syslinux/0004-utils-Use-the-host-toolchain-to-build.patch [new file with mode: 0644]
boot/syslinux/0005-lzo-Use-the-host-toolchain-for-prepcore.patch [new file with mode: 0644]
boot/syslinux/0005-utils-Use-the-host-toolchain-to-build.patch [deleted file]
boot/syslinux/0006-The-VPrint-definition-is-now-part-of-the-exports-of-.patch [new file with mode: 0644]
boot/syslinux/0006-lzo-Use-the-host-toolchain-for-prepcore.patch [deleted file]
boot/syslinux/0007-The-VPrint-definition-is-now-part-of-the-exports-of-.patch [deleted file]
boot/syslinux/0007-Update-the-longjump-calls-to-fit-the-new-declaration.patch [new file with mode: 0644]
boot/syslinux/0008-efi-wrapper-build-it-with-the-host-toolchain.patch [new file with mode: 0644]
boot/syslinux/0009-Update-the-longjump-calls-to-fit-the-new-declaration.patch [deleted file]
boot/syslinux/0010-efi-wrapper-build-it-with-the-host-toolchain.patch [deleted file]

diff --git a/boot/syslinux/0003-memdisk-Force-ld-output-format-to-32-bits.patch b/boot/syslinux/0003-memdisk-Force-ld-output-format-to-32-bits.patch
new file mode 100644 (file)
index 0000000..4eedf49
--- /dev/null
@@ -0,0 +1,32 @@
+From c0287594239d5af2082cac20817f8e8b11a4b1b2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
+Date: Wed, 5 Apr 2017 14:18:09 +0200
+Subject: [PATCH] memdisk: Force ld output format to 32-bits
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+On toolchains where the default output is x86_64, we need to be
+consistent with the other .o files
+
+Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
+---
+ memdisk/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/memdisk/Makefile b/memdisk/Makefile
+index e6557d8..06613ff 100644
+--- a/memdisk/Makefile
++++ b/memdisk/Makefile
+@@ -78,7 +78,7 @@ memdisk16.o: memdisk16.asm
+       $(NASM) -f bin $(NASMOPT) $(NFLAGS) $(NINCLUDE) -o $@ -l $*.lst $<
+ memdisk_%.o: memdisk_%.bin
+-      $(LD) -r -b binary -o $@ $<
++      $(LD) --oformat elf32-i386 -r -b binary -o $@ $<
+ memdisk16.elf: $(OBJS16)
+       $(LD) -Ttext 0 -o $@ $^
+-- 
+2.7.4
+
diff --git a/boot/syslinux/0004-memdisk-Force-ld-output-format-to-32-bits.patch b/boot/syslinux/0004-memdisk-Force-ld-output-format-to-32-bits.patch
deleted file mode 100644 (file)
index 4eedf49..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From c0287594239d5af2082cac20817f8e8b11a4b1b2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
-Date: Wed, 5 Apr 2017 14:18:09 +0200
-Subject: [PATCH] memdisk: Force ld output format to 32-bits
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-On toolchains where the default output is x86_64, we need to be
-consistent with the other .o files
-
-Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
----
- memdisk/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/memdisk/Makefile b/memdisk/Makefile
-index e6557d8..06613ff 100644
---- a/memdisk/Makefile
-+++ b/memdisk/Makefile
-@@ -78,7 +78,7 @@ memdisk16.o: memdisk16.asm
-       $(NASM) -f bin $(NASMOPT) $(NFLAGS) $(NINCLUDE) -o $@ -l $*.lst $<
- memdisk_%.o: memdisk_%.bin
--      $(LD) -r -b binary -o $@ $<
-+      $(LD) --oformat elf32-i386 -r -b binary -o $@ $<
- memdisk16.elf: $(OBJS16)
-       $(LD) -Ttext 0 -o $@ $^
--- 
-2.7.4
-
diff --git a/boot/syslinux/0004-utils-Use-the-host-toolchain-to-build.patch b/boot/syslinux/0004-utils-Use-the-host-toolchain-to-build.patch
new file mode 100644 (file)
index 0000000..e091a3a
--- /dev/null
@@ -0,0 +1,60 @@
+From e000251144056c99e390a2a4449d06cbd2a19c0a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
+Date: Wed, 5 Apr 2017 14:25:02 +0200
+Subject: [PATCH] utils: Use the host toolchain to build.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The utilities are meant to run on the host machine, hence must be built using
+the host toolchain.
+
+Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
+---
+ utils/Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/utils/Makefile b/utils/Makefile
+index dfe6259..ac91aaa 100644
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -17,8 +17,8 @@
+ VPATH = $(SRC)
+ include $(MAKEDIR)/syslinux.mk
+-CFLAGS   = $(GCCWARN) -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64 -I$(SRC)
+-LDFLAGS  = -O2
++CFLAGS   = $(CFLAGS_FOR_BUILD) $(GCCWARN) -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64 -I$(SRC)
++LDFLAGS  = $(LDFLAGS_FOR_BUILD) -O2
+ C_TARGETS      = isohybrid gethostip memdiskfind
+ SCRIPT_TARGETS         = mkdiskimage
+@@ -35,7 +35,7 @@ ISOHDPFX = $(addprefix $(OBJ)/,../mbr/isohdpfx.bin ../mbr/isohdpfx_f.bin \
+ all: $(TARGETS)
+ %.o: %.c
+-      $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
++      $(CC_FOR_BUILD) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
+ mkdiskimage: mkdiskimage.in ../mbr/mbr.bin bin2hex.pl
+       $(PERL) $(SRC)/bin2hex.pl < $(OBJ)/../mbr/mbr.bin | cat $(SRC)/mkdiskimage.in - > $@
+@@ -51,13 +51,13 @@ isohdpfx.c: $(ISOHDPFX) isohdpfxarray.pl
+       $(PERL) $(SRC)/isohdpfxarray.pl $(ISOHDPFX) > $@
+ isohybrid: isohybrid.o isohdpfx.o
+-      $(CC) $(LDFLAGS) -o $@ $^ -luuid
++      $(CC_FOR_BUILD) $(LDFLAGS) -o $@ $^ -luuid
+ gethostip: gethostip.o
+-      $(CC) $(LDFLAGS) -o $@ $^
++      $(CC_FOR_BUILD) $(LDFLAGS) -o $@ $^
+ memdiskfind: memdiskfind.o
+-      $(CC) $(LDFLAGS) -o $@ $^
++      $(CC_FOR_BUILD) $(LDFLAGS) -o $@ $^
+ tidy dist:
+       rm -f *.o .*.d isohdpfx.c
+-- 
+2.1.4
+
diff --git a/boot/syslinux/0005-lzo-Use-the-host-toolchain-for-prepcore.patch b/boot/syslinux/0005-lzo-Use-the-host-toolchain-for-prepcore.patch
new file mode 100644 (file)
index 0000000..c6fa7fe
--- /dev/null
@@ -0,0 +1,44 @@
+From 83e1f00990c25554723609bb549e18b987034317 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
+Date: Thu, 6 Apr 2017 09:43:46 +0200
+Subject: [PATCH] lzo: Use the host toolchain for prepcore
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
+---
+ lzo/Makefile | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/lzo/Makefile b/lzo/Makefile
+index 29f1fa6..c016e5a 100644
+--- a/lzo/Makefile
++++ b/lzo/Makefile
+@@ -11,10 +11,13 @@
+ ## -----------------------------------------------------------------------
+ VPATH = $(SRC)
+-include $(MAKEDIR)/build.mk
++include $(MAKEDIR)/syslinux.mk
+ INCLUDES += -I$(SRC)/include
++%.o: %.c
++      $(CC_FOR_BUILD) $(UMAKEDEPS) $(CFLAGS_FOR_BUILD) $(INCLUDES) -c -o $@ $<
++
+ LIBOBJS = $(patsubst %.c,%.o,$(subst $(SRC)/,,$(wildcard $(SRC)/src/*.c)))
+ LIB     = lzo.a
+ BINS    = prepcore
+@@ -30,7 +33,7 @@ $(LIB) : $(LIBOBJS)
+       $(RANLIB) $@
+ prepcore : prepcore.o $(LIB)
+-      $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
++      $(CC_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ $^ $(LIBS)
+ tidy dist clean spotless:
+       rm -f $(BINS)
+-- 
+2.1.4
+
diff --git a/boot/syslinux/0005-utils-Use-the-host-toolchain-to-build.patch b/boot/syslinux/0005-utils-Use-the-host-toolchain-to-build.patch
deleted file mode 100644 (file)
index e091a3a..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-From e000251144056c99e390a2a4449d06cbd2a19c0a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
-Date: Wed, 5 Apr 2017 14:25:02 +0200
-Subject: [PATCH] utils: Use the host toolchain to build.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The utilities are meant to run on the host machine, hence must be built using
-the host toolchain.
-
-Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
----
- utils/Makefile | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/utils/Makefile b/utils/Makefile
-index dfe6259..ac91aaa 100644
---- a/utils/Makefile
-+++ b/utils/Makefile
-@@ -17,8 +17,8 @@
- VPATH = $(SRC)
- include $(MAKEDIR)/syslinux.mk
--CFLAGS   = $(GCCWARN) -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64 -I$(SRC)
--LDFLAGS  = -O2
-+CFLAGS   = $(CFLAGS_FOR_BUILD) $(GCCWARN) -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64 -I$(SRC)
-+LDFLAGS  = $(LDFLAGS_FOR_BUILD) -O2
- C_TARGETS      = isohybrid gethostip memdiskfind
- SCRIPT_TARGETS         = mkdiskimage
-@@ -35,7 +35,7 @@ ISOHDPFX = $(addprefix $(OBJ)/,../mbr/isohdpfx.bin ../mbr/isohdpfx_f.bin \
- all: $(TARGETS)
- %.o: %.c
--      $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
-+      $(CC_FOR_BUILD) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
- mkdiskimage: mkdiskimage.in ../mbr/mbr.bin bin2hex.pl
-       $(PERL) $(SRC)/bin2hex.pl < $(OBJ)/../mbr/mbr.bin | cat $(SRC)/mkdiskimage.in - > $@
-@@ -51,13 +51,13 @@ isohdpfx.c: $(ISOHDPFX) isohdpfxarray.pl
-       $(PERL) $(SRC)/isohdpfxarray.pl $(ISOHDPFX) > $@
- isohybrid: isohybrid.o isohdpfx.o
--      $(CC) $(LDFLAGS) -o $@ $^ -luuid
-+      $(CC_FOR_BUILD) $(LDFLAGS) -o $@ $^ -luuid
- gethostip: gethostip.o
--      $(CC) $(LDFLAGS) -o $@ $^
-+      $(CC_FOR_BUILD) $(LDFLAGS) -o $@ $^
- memdiskfind: memdiskfind.o
--      $(CC) $(LDFLAGS) -o $@ $^
-+      $(CC_FOR_BUILD) $(LDFLAGS) -o $@ $^
- tidy dist:
-       rm -f *.o .*.d isohdpfx.c
--- 
-2.1.4
-
diff --git a/boot/syslinux/0006-The-VPrint-definition-is-now-part-of-the-exports-of-.patch b/boot/syslinux/0006-The-VPrint-definition-is-now-part-of-the-exports-of-.patch
new file mode 100644 (file)
index 0000000..c376010
--- /dev/null
@@ -0,0 +1,37 @@
+From 39274503292a6003b1b0c93f694e34f11e85ea44 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
+Date: Fri, 9 Jun 2017 11:55:14 +0200
+Subject: [PATCH] The VPrint definition is now part of the exports of
+ gnu-efi
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
+---
+ efi/fio.h | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/efi/fio.h b/efi/fio.h
+index 65fff8d..a1bfe68 100644
+--- a/efi/fio.h
++++ b/efi/fio.h
+@@ -11,15 +11,6 @@
+ #define MAX_EFI_ARGS          64
+ #define WS(c16)         (c16 == L' ' || c16 == CHAR_TAB)
+-/* VPrint is not in export declarations in gnu-efi lib yet
+- * although it is a global function; declare it here
+- */
+-extern UINTN
+-VPrint (
+-    IN CHAR16   *fmt,
+-    va_list     args
+-    );
+-
+ extern EFI_STATUS efi_errno;
+ void efi_memcpy(unsigned char *dst, unsigned char *src, size_t len);
+-- 
+2.1.4
+
diff --git a/boot/syslinux/0006-lzo-Use-the-host-toolchain-for-prepcore.patch b/boot/syslinux/0006-lzo-Use-the-host-toolchain-for-prepcore.patch
deleted file mode 100644 (file)
index c6fa7fe..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From 83e1f00990c25554723609bb549e18b987034317 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
-Date: Thu, 6 Apr 2017 09:43:46 +0200
-Subject: [PATCH] lzo: Use the host toolchain for prepcore
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
----
- lzo/Makefile | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/lzo/Makefile b/lzo/Makefile
-index 29f1fa6..c016e5a 100644
---- a/lzo/Makefile
-+++ b/lzo/Makefile
-@@ -11,10 +11,13 @@
- ## -----------------------------------------------------------------------
- VPATH = $(SRC)
--include $(MAKEDIR)/build.mk
-+include $(MAKEDIR)/syslinux.mk
- INCLUDES += -I$(SRC)/include
-+%.o: %.c
-+      $(CC_FOR_BUILD) $(UMAKEDEPS) $(CFLAGS_FOR_BUILD) $(INCLUDES) -c -o $@ $<
-+
- LIBOBJS = $(patsubst %.c,%.o,$(subst $(SRC)/,,$(wildcard $(SRC)/src/*.c)))
- LIB     = lzo.a
- BINS    = prepcore
-@@ -30,7 +33,7 @@ $(LIB) : $(LIBOBJS)
-       $(RANLIB) $@
- prepcore : prepcore.o $(LIB)
--      $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
-+      $(CC_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ $^ $(LIBS)
- tidy dist clean spotless:
-       rm -f $(BINS)
--- 
-2.1.4
-
diff --git a/boot/syslinux/0007-The-VPrint-definition-is-now-part-of-the-exports-of-.patch b/boot/syslinux/0007-The-VPrint-definition-is-now-part-of-the-exports-of-.patch
deleted file mode 100644 (file)
index c376010..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 39274503292a6003b1b0c93f694e34f11e85ea44 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
-Date: Fri, 9 Jun 2017 11:55:14 +0200
-Subject: [PATCH] The VPrint definition is now part of the exports of
- gnu-efi
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
----
- efi/fio.h | 9 ---------
- 1 file changed, 9 deletions(-)
-
-diff --git a/efi/fio.h b/efi/fio.h
-index 65fff8d..a1bfe68 100644
---- a/efi/fio.h
-+++ b/efi/fio.h
-@@ -11,15 +11,6 @@
- #define MAX_EFI_ARGS          64
- #define WS(c16)         (c16 == L' ' || c16 == CHAR_TAB)
--/* VPrint is not in export declarations in gnu-efi lib yet
-- * although it is a global function; declare it here
-- */
--extern UINTN
--VPrint (
--    IN CHAR16   *fmt,
--    va_list     args
--    );
--
- extern EFI_STATUS efi_errno;
- void efi_memcpy(unsigned char *dst, unsigned char *src, size_t len);
--- 
-2.1.4
-
diff --git a/boot/syslinux/0007-Update-the-longjump-calls-to-fit-the-new-declaration.patch b/boot/syslinux/0007-Update-the-longjump-calls-to-fit-the-new-declaration.patch
new file mode 100644 (file)
index 0000000..90d0b81
--- /dev/null
@@ -0,0 +1,37 @@
+From 3bd5c2d951421a89f76b2423e5810862f53486c1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
+Date: Fri, 9 Jun 2017 11:59:43 +0200
+Subject: [PATCH] Update the longjump calls to fit the new declaration
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
+---
+ efi/main.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/efi/main.c b/efi/main.c
+index 208fee4f..71d31a5c 100644
+--- a/efi/main.c
++++ b/efi/main.c
+@@ -10,7 +10,6 @@
+ #include <syslinux/firmware.h>
+ #include <syslinux/linux.h>
+ #include <sys/ansi.h>
+-#include <setjmp.h>
+ #include "efi.h"
+ #include "fio.h"
+@@ -30,7 +29,7 @@ uint32_t timer_irq;
+ __export uint8_t KbdMap[256];
+ char aux_seg[256];
+-static jmp_buf load_error_buf;
++static jmp_buf *load_error_buf;
+ static inline EFI_STATUS
+ efi_close_protocol(EFI_HANDLE handle, EFI_GUID *guid, EFI_HANDLE agent,
+-- 
+2.13.3
+
diff --git a/boot/syslinux/0008-efi-wrapper-build-it-with-the-host-toolchain.patch b/boot/syslinux/0008-efi-wrapper-build-it-with-the-host-toolchain.patch
new file mode 100644 (file)
index 0000000..9ec12a1
--- /dev/null
@@ -0,0 +1,32 @@
+From ca8aaded0c7c3900397029bd9520132b62629308 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
+Date: Mon, 12 Jun 2017 14:59:16 +0200
+Subject: [PATCH] efi/wrapper: build it with the host toolchain.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The wrapper program is executed on the build machine, so it should be
+built with CC_FOR_BUILD.
+
+Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
+---
+ efi/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/efi/Makefile b/efi/Makefile
+index d5443bd5..d24d16db 100644
+--- a/efi/Makefile
++++ b/efi/Makefile
+@@ -79,7 +79,7 @@ syslinux.so: $(OBJS) $(CORE_OBJS) $(LIB_OBJS)
+ #     cp $^ $@
+ wrapper: wrapper.c
+-      $(CC) $^ -o $@
++      $(CC_FOR_BUILD) $^ -o $@
+ #
+ # Build the wrapper app and wrap our .so to produce a .efi
+-- 
+2.13.3
+
diff --git a/boot/syslinux/0009-Update-the-longjump-calls-to-fit-the-new-declaration.patch b/boot/syslinux/0009-Update-the-longjump-calls-to-fit-the-new-declaration.patch
deleted file mode 100644 (file)
index cb36998..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From db49dbac8a0c563fb6d07c348873e8ae50fee2a6 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
-Date: Fri, 9 Jun 2017 11:59:43 +0200
-Subject: [PATCH] Update the longjump calls to fit the new declaration
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
----
- efi/main.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/efi/main.c b/efi/main.c
-index fd95f5c..b5383cd 100644
---- a/efi/main.c
-+++ b/efi/main.c
-@@ -10,7 +10,6 @@
- #include <syslinux/firmware.h>
- #include <syslinux/linux.h>
- #include <sys/ansi.h>
--#include <setjmp.h>
- #include "efi.h"
- #include "fio.h"
-@@ -31,7 +30,7 @@ uint32_t timer_irq;
- __export uint8_t KbdMap[256];
- char aux_seg[256];
--static jmp_buf load_error_buf;
-+static jmp_buf *load_error_buf;
- EFI_HANDLE image_handle, image_device_handle, mnpsb_handle;
--- 
-2.1.4
-
diff --git a/boot/syslinux/0010-efi-wrapper-build-it-with-the-host-toolchain.patch b/boot/syslinux/0010-efi-wrapper-build-it-with-the-host-toolchain.patch
deleted file mode 100644 (file)
index c8ff9eb..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 755c947e9166366bd1a78efb1e0c7d6e6e2daa07 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
-Date: Mon, 12 Jun 2017 14:59:16 +0200
-Subject: [PATCH] efi/wrapper: build it with the host toolchain.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The wrapper program is executed on the build machine, so it should be
-built with CC_FOR_BUILD.
-
-Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
----
- efi/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/efi/Makefile b/efi/Makefile
-index d3788d9..a17258a 100644
---- a/efi/Makefile
-+++ b/efi/Makefile
-@@ -78,7 +78,7 @@ syslinux.so: $(OBJS) $(CORE_OBJS) $(LIB_OBJS)
- #     cp $^ $@
- wrapper: wrapper.c
--      $(CC) $^ -o $@
-+      $(CC_FOR_BUILD) $^ -o $@
- #
- # Build the wrapper app and wrap our .so to produce a .efi
--- 
-2.1.4
-