package/mpd: add libid3tag optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Aug 2020 21:19:40 +0000 (23:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 18 Aug 2020 21:49:23 +0000 (23:49 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index f1f8d99465cc4fe5e237c877f39142ee147a9fce..fbde82ab58d6ccf7af6b5ae1e0b30f01d57f67b4 100644 (file)
@@ -395,6 +395,14 @@ config BR2_PACKAGE_MPD_UPNP
        help
          Enable MPD UPnP client support.
 
+comment "Tag plugins"
+
+config BR2_PACKAGE_MPD_ID3TAG
+       bool "id3tag"
+       select BR2_PACKAGE_LIBID3TAG
+       help
+         Enable ID3 support.
+
 endif
 
 comment "mpd needs a toolchain w/ C++, threads, wchar, gcc >= 6"
index 566b105f6131dfafa6bdd7e979c4cb34f6f19fb1..65f9c6f2e0ec32d15a42ee8aafe4e7ad0aaa9ef3 100644 (file)
@@ -110,6 +110,13 @@ else
 MPD_CONF_OPTS += -Dhttpd=false
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_ID3TAG),y)
+MPD_DEPENDENCIES += libid3tag
+MPD_CONF_OPTS += -Did3tag=enabled
+else
+MPD_CONF_OPTS += -Did3tag=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_JACK2),y)
 MPD_DEPENDENCIES += jack2
 MPD_CONF_OPTS += -Djack=enabled