portmap: fix static linking
authorANDY KENNEDY <ANDY.KENNEDY@adtran.com>
Mon, 8 Sep 2014 21:43:45 +0000 (21:43 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Sep 2014 20:07:02 +0000 (22:07 +0200)
Portmap builds and links, however, does not get built correctly when
BR2_PREFER_STATIC_LIB is selected.  There are no dynamic libraries in
rootfs.tar, however, portmap gets linked dynamically without regards to
the PREFER_STATIC_LIB tags.  LDFLAGS was not being passed into the build of
portmap.

Signed-off-by: Andy Kennedy <andy.kennedy@adtran.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/portmap/portmap.mk

index 82035553ee7e2541919228c5f8d4ac8528e91e1d..01895976a6a778026586405f002edfa2cd6a0a73 100644 (file)
@@ -17,8 +17,7 @@ PORTMAP_FLAGS += NO_FORK=1
 endif
 
 define PORTMAP_BUILD_CMDS
-       CFLAGS="$(TARGET_CFLAGS)" \
-       $(MAKE) CC="$(TARGET_CC)" -C $(@D) $(PORTMAP_FLAGS)
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) $(PORTMAP_FLAGS)
 endef
 
 define PORTMAP_INSTALL_TARGET_CMDS