package/qt5/qt5base: fix PKG_CONFIG_LIBDIR
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 2 Aug 2018 18:09:44 +0000 (20:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 5 Aug 2018 10:54:51 +0000 (12:54 +0200)
By default pkgconf searches "${libdir}/pkgconfig:${datadir}/pkgconfig"
for .pc files:
https://github.com/pkgconf/pkgconf/blob/844f0a66621629a65e3cbf3c3ca47185602e9df5/configure.ac#L41

The new xorgproto package installs .pc files to ${datadir}/pkgconfig
whichs translates to $(STAGING_DIR)/usr/share/pkgconfig, for example
dri3proto:
https://cgit.freedesktop.org/xorg/proto/xorgproto/tree/Makefile.am#n65

whereas the old xproto_ packages installed their .pc files to
${libdir}/pkgconfig:
https://cgit.freedesktop.org/xorg/proto/dri3proto/tree/Makefile.am?id=3937f72040b79c7245b261da880364177cc40a6e#n4

Normally this upstream change is not a problem because pkgconf searches
both paths for .pc files, unless we define PKG_CONFIG_LIBDIR with
something else like we did for the last six years ;)
https://github.com/buildroot/buildroot/blame/master/package/qt5/qt5base/qt5base.mk#L280

This patch removes all variables concerning pkgconf paths. At the time
the qt5base package was introduced the pkgconf wrapper did not exist.
Today these variables are not necessary anymore.

Fixes
http://autobuild.buildroot.net/results/061/06159500c27026d56a772fafbb0d956c72dd4e6c/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5base/qt5base.mk

index 9eafd593f13d281db4c04edfc910ec81825c0d27..ab2b883fc4a7332053f2abc959cb09646239e94c 100644 (file)
@@ -277,8 +277,6 @@ define QT5BASE_CONFIGURE_CMDS
        (cd $(@D); \
                $(TARGET_MAKE_ENV) \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
-               PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
                MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)" \
                ./configure \
                -v \