fixup kernel compile
authorEric Andersen <andersen@codepoet.org>
Tue, 22 Feb 2005 08:46:49 +0000 (08:46 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 22 Feb 2005 08:46:49 +0000 (08:46 -0000)
target/device/Soekris/Makefile.in
target/device/Soekris/net4521/linux.mk

index 5a00e9b0f7d0dc532f207a256007fea80a042b2f..4aaf1ef8e9d5d1067cfda0d0b9dfb6ebcbe3ba2c 100644 (file)
@@ -3,3 +3,9 @@ ifeq ($(strip $(BR2_TARGET_SOEKRIS_NET4521)),y)
 UCLIBC_CONFIG_FILE:=target/device/Soekris/net4521/uClibc.config
 BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
 endif
+
+ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
+include target/device/Soekris/net4521/linux.mk
+TARGETS+=linux
+endif
+
index 2d29a6a3ec7be4a38c3f867792d50f8c4fa02d59..a081eec4c4dfd4eada20497e6fcebc23c1c96f78 100644 (file)
@@ -19,7 +19,6 @@
 #  -Erik
 #
 #############################################################
-ifneq ($(filter $(TARGETS),linux),)
 
 # Version of Linux to download and then apply patches to
 DOWNLOAD_LINUX_VERSION=2.4.29
@@ -110,12 +109,3 @@ linuxclean: clean
 linux-dirclean:
        rm -rf $(LINUX_DIR)
 
-endif
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
-TARGETS+=linux
-endif