toolchain-external: remove unused calculation of ARCH_SUBDIR
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Fri, 12 Feb 2016 19:20:23 +0000 (20:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 Apr 2016 21:30:20 +0000 (23:30 +0200)
In TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LIBS, ARCH_SUBDIR is calculated but not
used, and can thus be removed. Since SYSROOT_DIR is only used for the
calculation of ARCH_SUBDIR, it can be removed too.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/toolchain-external.mk

index ff4ae5e219eaa75e53ee312c1a04a211fecf2d56..66ba23ad9bc721c0aa73f75ad2006ec6b0e055ad 100644 (file)
@@ -617,12 +617,7 @@ endef
 #                       to the target filesystem.
 
 define TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LIBS
-       $(Q)SYSROOT_DIR="$(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC))" ; \
-       if test -z "$${SYSROOT_DIR}" ; then \
-               @echo "External toolchain doesn't support --sysroot. Cannot use." ; \
-               exit 1 ; \
-       fi ; \
-       ARCH_SYSROOT_DIR="$(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS))" ; \
+       $(Q)ARCH_SYSROOT_DIR="$(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS))" ; \
        ARCH_LIB_DIR="$(call toolchain_find_libdir,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS))" ; \
        SUPPORT_LIB_DIR="" ; \
        if test `find $${ARCH_SYSROOT_DIR} -name 'libstdc++.a' | wc -l` -eq 0 ; then \
@@ -631,7 +626,6 @@ define TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LIBS
                        SUPPORT_LIB_DIR=`readlink -f $${LIBSTDCPP_A_LOCATION} | sed -r -e 's:libstdc\+\+\.a::'` ; \
                fi ; \
        fi ; \
-       ARCH_SUBDIR=`echo $${ARCH_SYSROOT_DIR} | sed -r -e "s:^$${SYSROOT_DIR}(.*)/$$:\1:"` ; \
        if test -z "$(BR2_STATIC_LIBS)" ; then \
                $(call MESSAGE,"Copying external toolchain libraries to target...") ; \
                for libs in $(LIB_EXTERNAL_LIBS); do \