pkg-infra: pass --disable-doc if documentation is not enabled
authorArnout Vandecappelle <arnout@mind.be>
Wed, 12 Dec 2012 04:07:22 +0000 (04:07 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 12 Dec 2012 16:11:15 +0000 (17:11 +0100)
Many configure scripts support an option like --disable-doc, --disable-docs
or --disable-documentation.  Pass all of these to configure.

In addition, not all Xorg packages accept the --disable-xxx. Instead they
look for xmlto and/or fop and build documentation if they exist.  For host
packages, this may lead to build errors because /usr/bin/xmlto uses libxml2
and we set LD_LIBRARY_PATH to point to $(HOST_DIR)/lib, which may contain
a libxml2 as well.  So it's essential to disable xmlto for host packages.

Also some whitespace cleanup.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in
package/pkg-autotools.mk

index 4281773a31ee7e43e0b5e6ccbd1f19181f091b33..cc8f3202c8f39ce5f4aa05f8325ffc3dc975f61c 100644 (file)
@@ -290,7 +290,15 @@ DISABLE_LARGEFILE= --disable-largefile
 endif
 
 ifneq ($(BR2_HAVE_DOCUMENTATION),y)
-DISABLE_DOCUMENTATION=--disable-gtk-doc
+# The configure option varies, but since unknown options are ignored
+# we can pass all of them.
+DISABLE_DOCUMENTATION = \
+       --disable-gtk-doc \
+       --disable-doc \
+       --disable-docs \
+       --disable-documentation \
+       --with-xmlto=no \
+       --with-fop=no
 endif
 
 ifeq ($(BR2_INET_IPV6),y)
index 785daab0e121e102951034c7194929d30bb3e48b..890506bbc2d3d12cf2cd90c0aef6f1d21653fc27 100644 (file)
@@ -116,6 +116,9 @@ endef
 else
 
 # Configure package for host
+# disable all kind of documentation generation in the process,
+# because it often relies on host tools which may or may not be
+# installed.
 define $(2)_CONFIGURE_CMDS
        (cd $$($$(PKG)_SRCDIR) && rm -rf config.cache; \
                $$(HOST_CONFIGURE_OPTS) \
@@ -126,6 +129,12 @@ define $(2)_CONFIGURE_CMDS
                --prefix="$$(HOST_DIR)/usr" \
                --sysconfdir="$$(HOST_DIR)/etc" \
                --enable-shared --disable-static \
+               --disable-gtk-doc \
+               --disable-doc \
+               --disable-docs \
+               --disable-documentation \
+               --with-xmlto=no \
+               --with-fop=no \
                $$($$(PKG)_CONF_OPT) \
        )
 endef