package/nodejs: use shared libhttpparser
authorMartin Bark <martin@barkynet.com>
Tue, 18 Jul 2017 11:45:42 +0000 (12:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 19 Jul 2017 19:59:20 +0000 (21:59 +0200)
nodejs requires libhttpparser and by default will use an internal copy
bundled with the release.  Change to using a shared libhttpparser library.

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nodejs/Config.in
package/nodejs/nodejs.mk

index f90ca2b3fbae1ce6cd8d05cc6ebc2d23c226b30a..a96901a31c55fc4183ae34164d8ecdc6d5950d59 100644 (file)
@@ -25,6 +25,7 @@ config BR2_PACKAGE_NODEJS
        # linking, but that's too much of a corner case to support it.
        depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_C_ARES
+       select BR2_PACKAGE_LIBHTTPPARSER
        select BR2_PACKAGE_ZLIB
        help
          Event-driven I/O server-side JavaScript environment based on V8.
index 5bf8889ea9169360e1811ae1a6ef521faf6bb463..f4e59697326dac3bc746c4a30c5273012fd8919c 100644 (file)
@@ -7,7 +7,8 @@
 NODEJS_VERSION = 8.1.4
 NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
 NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
-NODEJS_DEPENDENCIES = host-python host-nodejs c-ares zlib \
+NODEJS_DEPENDENCIES = host-python host-nodejs c-ares \
+       libhttpparser zlib \
        $(call qstrip,$(BR2_PACKAGE_NODEJS_MODULES_ADDITIONAL_DEPS))
 HOST_NODEJS_DEPENDENCIES = host-python host-zlib
 NODEJS_LICENSE = MIT (core code); MIT, Apache and BSD family licenses (Bundled components)
@@ -17,6 +18,7 @@ NODEJS_CONF_OPTS = \
        --without-snapshot \
        --shared-zlib \
        --shared-cares \
+       --shared-http-parser \
        --without-dtrace \
        --without-etw \
        --dest-os=linux