If you update the kernel headers tarball and run make against an already built
authorEric Andersen <andersen@codepoet.org>
Thu, 23 Jun 2005 23:25:25 +0000 (23:25 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 23 Jun 2005 23:25:25 +0000 (23:25 -0000)
buildroot, the header files will be re-extracted, but they will not be put in
exactly the right place if the name of the extracted directory includes the
kernel version numbers.

For example, linux-libc-headers-2.4.25.tar.bz2 will be extracted to
$(TOOLCHAIN_BUILD_DIR)/linux-libc-headers-2.4.25, and then the mv command will
move the newly extracted headers into the already existing
$(TOOLCHAIN_BUILD_DIR)/linux directory, instead of replacing that directory as
desired.

The fix is to first remove the $(TOOLCHAIN_BUILD_DIR)/linux directory and then
do the mv command.

http://bugs.busybox.net/view.php?id=296

toolchain/kernel-headers/kernel-headers.mk

index 56a0566e9d036c8a8c215e0fe452a5c9ee941c9f..e9ca5dc04221a7c1e9f6f244ee55e5a09a66c907 100644 (file)
@@ -78,6 +78,7 @@ $(DL_DIR)/$(LINUX_HEADERS_SOURCE):
        $(WGET) -P $(DL_DIR) $(LINUX_HEADERS_SITE)/$(LINUX_HEADERS_SOURCE)
 
 $(LINUX_HEADERS_DIR)/.unpacked: $(DL_DIR)/$(LINUX_HEADERS_SOURCE)
+       rm -rf $(LINUX_HEADERS_DIR)
        mkdir -p $(TOOL_BUILD_DIR)
        bzcat $(DL_DIR)/$(LINUX_HEADERS_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
 ifneq ($(LINUX_HEADERS_UNPACK_DIR),$(LINUX_HEADERS_DIR))