linux: add support for linux26-{menuconfig,xconfig,gconfig} targets
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 13 Jun 2010 17:18:34 +0000 (19:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Jun 2010 19:20:27 +0000 (21:20 +0200)
These targets allow the user to customize the configuration of the
Linux kernel. After changing the kernel configuration, the next time
the user runs "make", the kernel is rebuilt to take into account the
new configuration (not rebuilt from scratch).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 71d9616034fb0fd1091c005f383b8108f15d2d20..d1f1842f717a838f5ef698affc667ae467813f54 100644 (file)
@@ -98,8 +98,9 @@ endif
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
        $(Q)touch $@
 
-# Compilation
-$(LINUX26_DIR)/.stamp_compiled: $(LINUX26_DIR)/.stamp_configured
+# Compilation. We make sure the kernel gets rebuilt when the
+# configuration has changed.
+$(LINUX26_DIR)/.stamp_compiled: $(LINUX26_DIR)/.stamp_configured $(LINUX26_DIR)/.config
        @$(call MESSAGE,"Compiling kernel")
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) $(LINUX26_IMAGE_NAME)
        @if [ $(shell grep -c "CONFIG_MODULES=y" $(LINUX26_DIR)/.config) != 0 ] ; then  \
@@ -123,6 +124,9 @@ $(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
 
 linux26: host-module-init-tools $(LINUX26_DEPENDENCIES) $(LINUX26_DIR)/.stamp_installed
 
+linux26-menuconfig linux26-xconfig linux26-gconfig: $(LINUX26_DIR)/.stamp_configured
+       $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) $(subst linux26-,,$@)
+
 ifeq ($(BR2_LINUX_KERNEL),y)
 TARGETS+=linux26
 endif