python-configobj: new package
authorZoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Wed, 11 Dec 2013 20:27:01 +0000 (21:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:41:31 +0000 (13:41 +0100)
[Thomas: convert to the Python package infrastructure.]

Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-configobj/Config.in [new file with mode: 0644]
package/python-configobj/python-configobj.mk [new file with mode: 0644]

index a884de1d5954b3b02dc28e8ae633be32e6bfefb7..3316d0fe6eed9f044506a145b8e5966e0a7ddefa 100644 (file)
@@ -386,6 +386,7 @@ source "package/python/Config.in"
 if BR2_PACKAGE_PYTHON
 menu "external python modules"
 source "package/python-bottle/Config.in"
+source "package/python-configobj/Config.in"
 source "package/python-crc16/Config.in"
 source "package/python-dialog/Config.in"
 source "package/python-dpkt/Config.in"
diff --git a/package/python-configobj/Config.in b/package/python-configobj/Config.in
new file mode 100644 (file)
index 0000000..fc57e26
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_CONFIGOBJ
+       bool "python-configobj"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         ConfigObj is a simple but powerful config file reader and
+         writer: an ini file round tripper. Its main feature is that
+         it is very easy to use, with a straightforward programmer's
+         interface and a simple syntax for config files.
+
+         http://www.voidspace.org.uk/python/configobj.html
diff --git a/package/python-configobj/python-configobj.mk b/package/python-configobj/python-configobj.mk
new file mode 100644 (file)
index 0000000..5211b1d
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-configobj
+#
+################################################################################
+
+PYTHON_CONFIGOBJ_VERSION = 4.7.2
+PYTHON_CONFIGOBJ_SOURCE = configobj-$(PYTHON_CONFIGOBJ_VERSION).tar.gz
+PYTHON_CONFIGOBJ_SITE = http://pypi.python.org/packages/source/c/configobj
+PYTHON_CONFIGOBJ_LICENSE = BSD-3c
+# License only mentioned in the source
+PYTHON_CONFIGOBJ_SETUP_TYPE = distutils
+
+$(eval $(python-package))