Från: Brad House <brad@mainstreetsoftworks.com>
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 19 Aug 2007 21:02:46 +0000 (21:02 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 19 Aug 2007 21:02:46 +0000 (21:02 -0000)
Till:  buildroot@uclibc.org
Ämne:  [Buildroot] [patch] php fixes and updates
Datum:  Tue, 14 Aug 2007 16:39:03 -0400  (22.39 CEST)
Changes:
        - fastcgi config option
        - force php to find the php.ini in /etc (it seems to default
          to /lib for some reason)
        - build with posix support, a lot of php scripts require
          this apparently
        - strip the php binary when installing to TARGET_DIR
        - actually 'uninstall' php on a php-clean

-Brad

package/php/Config.in
package/php/php.mk

index e8e861db49bf617c85566bca5ae128dc693d73f7..e5d4ff3b886e959374e6c00ea0d8bc055da7e206 100644 (file)
@@ -24,6 +24,13 @@ config BR2_PACKAGE_PHP_CGI
           cgi interface for php
           you must have at least cli or cgi selected.
 
+config BR2_PACKAGE_PHP_FASTCGI
+        bool "fastcgi"
+        depends on BR2_PACKAGE_PHP_CGI
+        default y
+        help
+          fast cgi interface for php
+
 config BR2_PACKAGE_PHP_OPENSSL
         bool "openssl support"
         depends on BR2_PACKAGE_PHP && BR2_PACKAGE_OPENSSL
index cf4422f6f2bce17051f83a9acecc8251b985e0ef..f9550d9323d955736c7891050006d46cc8572c17 100644 (file)
@@ -19,10 +19,13 @@ else
 endif
 
 ifneq ($(BR2_PACKAGE_PHP_CGI),y)
-       PHP_CGI="--disable-cgi"
+       PHP_CGI=--disable-cgi
 else
-       PHP_CGI="--enable-cgi"
+       PHP_CGI=--enable-cgi
        PHP_TARGET_DEPS+=$(TARGET_DIR)/usr/bin/php-cgi
+       ifeq ($(BR2_PACKAGE_PHP_FASTCGI),y)
+               PHP_CGI+=--enable-fastcgi
+       endif
 endif
 
 ifeq ($(BR2_PACKAGE_PHP_OPENSSL),y)
@@ -69,6 +72,7 @@ $(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
                --sbindir=/usr/sbin \
                --libexecdir=/usr/lib \
                --sysconfdir=/etc \
+               --with-config-file-path=/etc \
                --datadir=/usr/share/misc \
                --localstatedir=/var \
                --mandir=/usr/man \
@@ -77,6 +81,7 @@ $(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
                --enable-spl \
                --enable-session \
                --enable-sockets \
+               --enable-posix \
                --with-pcre-regex \
                --without-pear \
                --disable-ipv6 \
@@ -100,10 +105,12 @@ $(PHP_DIR)/.staged: $(PHP_DIR)/.built
 $(TARGET_DIR)/usr/bin/php: $(PHP_DIR)/.staged
        cp -dpf $(STAGING_DIR)/usr/bin/php $(TARGET_DIR)/usr/bin/php
        chmod 755 $(TARGET_DIR)/usr/bin/php
+       $(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/php
 
 $(TARGET_DIR)/usr/bin/php-cgi: $(PHP_DIR)/.staged
        cp -dpf $(STAGING_DIR)/usr/bin/php-cgi $(TARGET_DIR)/usr/bin/php-cgi
        chmod 755 $(TARGET_DIR)/usr/bin/php-cgi
+       $(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/php-cgi
 
 $(TARGET_DIR)/etc/php.ini: $(PHP_DIR)/.staged
        cp $(PHP_DIR)/php.ini-dist $(TARGET_DIR)/etc/php.ini
@@ -112,6 +119,9 @@ php: uclibc $(PHP_DEPS) $(PHP_TARGET_DEPS) $(TARGET_DIR)/etc/php.ini
 
 php-clean:
        rm -f $(PHP_DIR)/.configured $(PHP_DIR)/.built $(PHP_DIR)/.staged
+       rm -f $(TARGET_DIR)/usr/bin/php $(TARGET_DIR)/usr/bin/php-cgi
+       rm -f $(STAGING_DIR)/usr/bin/php* $(STAGING_DIR)/usr/man/man1/php*
+       rm -rf $(STAGING_DIR)/usr/include/php
        -$(MAKE) -C $(PHP_DIR) clean
 
 php-dirclean: