package/sshfs: bump to version 3.7.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 25 Oct 2020 09:37:42 +0000 (10:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Oct 2020 10:03:43 +0000 (11:03 +0100)
- libfuse3 is needed since version 3.0.0 and
  https://github.com/libfuse/sshfs/commit/34146444ce20c477cba7e9fe113e4387da32ae94
- Switch to meson-package

https://github.com/libfuse/sshfs/blob/sshfs-3.7.0/ChangeLog.rst

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sshfs/Config.in
package/sshfs/sshfs.hash
package/sshfs/sshfs.mk

index 7383b6094d70ca09b50915a5b4253d5185ac6879..bc54b698d82b7d54f2392bebf4959d87d349cf0b 100644 (file)
@@ -1,10 +1,10 @@
 config BR2_PACKAGE_SSHFS
        bool "sshfs (FUSE)"
        depends on BR2_USE_WCHAR # glib2
-       depends on BR2_TOOLCHAIN_HAS_THREADS # libfuse, glib2
-       depends on BR2_USE_MMU # libfuse, glib2
-       depends on !BR2_STATIC_LIBS # libfuse
-       select BR2_PACKAGE_LIBFUSE
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libfuse3, glib2
+       depends on BR2_USE_MMU # libfuse3, glib2
+       depends on !BR2_STATIC_LIBS # libfuse3
+       select BR2_PACKAGE_LIBFUSE3
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_OPENSSH
index a8878e6931f5c2a778cfddb367b508e3f7cd9d34..b8488013a72b159aa3bb5b9cebe88ba26d837802 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated after checking pgp signature
-sha256  7f689174d02e6b7e2631306fda4fb8e6b4483102d1bce82b3cdafba33369ad22  sshfs-2.8.tar.gz
+sha256  6e7e86831f3066b356e7f16e22f1b8a8f177fda05146f6a5eb821c2fd0541c34  sshfs-3.7.0.tar.xz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
index ee96ad67e8c7d2de8186ae8d604bdf552947a5d4..70e7feab1d212eaad5e9a0b3824b7aac0165a423 100644 (file)
@@ -4,13 +4,14 @@
 #
 ################################################################################
 
-SSHFS_VERSION = 2.8
-SSHFS_SITE = https://github.com/libfuse/sshfs/releases/download/sshfs_$(SSHFS_VERSION)
+SSHFS_VERSION = 3.7.0
+SSHFS_SOURCE = sshfs-$(SSHFS_VERSION).tar.xz
+SSHFS_SITE = https://github.com/libfuse/sshfs/releases/download/sshfs-$(SSHFS_VERSION)
 SSHFS_LICENSE = GPL-2.0
 SSHFS_LICENSE_FILES = COPYING
 SSHFS_DEPENDENCIES = \
-       libglib2 libfuse openssh \
+       libglib2 libfuse3 openssh \
        $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_ENABLE_LOCALE),,libiconv)
 
-$(eval $(autotools-package))
+$(eval $(meson-package))