clamav: fix configure breakage after zlib 1.2.10 version bump
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 4 Jan 2017 15:27:34 +0000 (16:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 4 Jan 2017 16:04:18 +0000 (17:04 +0100)
Fixes:
http://autobuild.buildroot.net/results/b6b/b6ba2dfb42ee41ed0b8304aa8c78645245f3b341/
http://autobuild.buildroot.net/results/eef/eef9a2dda2c172cd600dc74c1e5e60476d92280d/
http://autobuild.buildroot.net/results/827/82798118795aa6334b4dd6eac06777682131da7f/

The clamav configure script by default checks for old zlib versions with
known vulnerabilities and errors out if found:

configure: error: The installed zlib version may contain a security bug.
Please upgrade to 1.2.2 or later: http://www.zlib.net.  You can omit this
check with --disable-zlib-vcheck but DO NOT REPORT any stability issues
then!

The check is unfortunately not very robust as it simply checks for a version
string matching '1.2.1' (which 1.2.10 does):

vuln=`grep "ZLIB_VERSION \"1.2.1" $ZLIB_HOME/include/zlib.h`

As a workaround, pass --disable-zlib-vcheck to skip this check.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/clamav/clamav.mk

index 6a82d66ca9326b59af58f3a034a5665160dede60..36ab8be0e9f38e0e2e52ee154e74336d37b3c083 100644 (file)
@@ -26,6 +26,7 @@ CLAMAV_CONF_OPTS = \
        --with-dbdir=/var/lib/clamav \
        --with-openssl=$(STAGING_DIR)/usr \
        --with-zlib=$(STAGING_DIR)/usr \
+       --disable-zlib-vcheck \
        --disable-rpath \
        --disable-clamav \
        --disable-fanotify \