package/alsa-utils: add a WantedBy section to the systemd unit file
authorJérémy Rosen <jeremy.rosen@smile.fr>
Mon, 16 Dec 2019 10:30:52 +0000 (11:30 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Dec 2019 17:33:22 +0000 (18:33 +0100)
This allows the user to enable/disable manually the unit.
It is enabled by default

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
[yann.morin.1998@free.fr:
  - split logn lines
  - no need for continued line (no use for ';\' )
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/alsa-utils/alsa-utils.mk

index 52022e32ab6117b7709675171b179dabefaf791c..2cd3c4a333856effd9e7e8605a648fe150d58e26 100644 (file)
@@ -90,11 +90,12 @@ define ALSA_UTILS_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service
        $(INSTALL) -D -m 0644 $(@D)/alsactl/alsa-state.service \
                $(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service
-       mkdir -p $(TARGET_DIR)/etc/systemd/system/sound.target.wants
-       ln -sf ../../../../lib/systemd/system/alsa-restore.service \
-               $(TARGET_DIR)/etc/systemd/system/sound.target.wants/alsa-restore.service
-       ln -sf ../../../../lib/systemd/system/alsa-state.service \
-               $(TARGET_DIR)/etc/systemd/system/sound.target.wants/alsa-state.service
+       mkdir $(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service.d
+       printf '[Install]\nWantedBy=multi-user.target\n' \
+               >$(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service.d/buildroot-enable.conf
+       mkdir $(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service.d
+       printf '[Install]\nWantedBy=multi-user.target\n' \
+               >$(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service.d/buildroot-enable.conf;
 endef
 endif