package/poppler: add boost optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 19 Jan 2021 18:05:42 +0000 (19:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 21 Jan 2021 21:40:51 +0000 (22:40 +0100)
boost is an optional dependency which is enabled by default since
version 0.80.0 and
https://github.com/freedesktop/poppler/commit/355fd8d58ca0209284fe568b3add28f207e995c1

There is no cmake option to enable or disable this dependency

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/poppler/poppler.mk

index 8e8dafc715ae8b42bab99cb98843cbefe1c0d1b1..e779a7c9d3b90e32fdac265d68ef9b2e22efdcf9 100644 (file)
@@ -26,6 +26,10 @@ ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 POPPLER_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
 endif
 
+ifeq ($(BR2_PACKAGE_BOOST),y)
+POPPLER_DEPENDENCIES += boost
+endif
+
 ifeq ($(BR2_PACKAGE_JPEG),y)
 POPPLER_DEPENDENCIES += jpeg
 POPPLER_CONF_OPTS += -DENABLE_DCTDECODER=libjpeg -DWITH_JPEG=ON