erlang-rebar: fix license variables
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2016 15:58:29 +0000 (16:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2016 15:58:29 +0000 (16:58 +0100)
The erlang-rebar package uses ERLANG_ as the prefix for its license
variables, therefore overriding the license information from the
erlang package. This commit fixes this by using the appropriate
ERLANG_REBAR_ suffix.

Reported-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang-rebar/erlang-rebar.mk

index f29eb756976383d6c5748ced2cdd84c072f6f064..d2189e1f7ca30c97bc21878f60f9b4d3a2009660 100644 (file)
@@ -13,8 +13,8 @@ ERLANG_REBAR_SITE = $(call github,rebar,rebar,$(ERLANG_REBAR_VERSION))
 
 # Although the file LICENSE state Apache-2.0, a lot (if not all) the files
 # in src/ bear the MIT licence.
-ERLANG_LICENSE = Apache-2.0, MIT
-ERLANG_LICENSE_FILES = LICENSE
+ERLANG_REBAR_LICENSE = Apache-2.0, MIT
+ERLANG_REBAR_LICENSE_FILES = LICENSE
 
 # We do not have a target variant, so just define the dependencies,
 # configure and build commands for the host variant.