audit: do not remove file installed by netplug
authorCarlos Santos <casantos@datacom.com.br>
Tue, 5 Jun 2018 02:08:42 +0000 (23:08 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 5 Jun 2018 07:49:15 +0000 (09:49 +0200)
The package recipe uses a post-install hook to remove useless files from
$(TARGET_DIR)/etc/rc.d/init.d and $(TARGET_DIR)/etc/sysconfig. This may
damage packages that install useful files on those directories (such as
netplug, which installs $(TARGET_DIR)/etc/rc.d/init.d/netplugd).

In the future[1] we will reorganize the init scripts and possibly get
rid of /etc/rc.d and /etc/sysconfig but for the moment let's restrict
the file removal to those installed by audit.

1. http://lists.busybox.net/pipermail/buildroot/2018-May/221549.html

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/audit/audit.mk

index f5aa00d2f099b7afdf216bf71a6e82f547323e03..2f6e6653b3aa4d3d82dc74d28bbd421e45102a74 100644 (file)
@@ -51,8 +51,8 @@ define AUDIT_INSTALL_INIT_SYSTEMD
 endef
 
 define AUDIT_INSTALL_CLEANUP
-       $(RM) -rf $(TARGET_DIR)/etc/rc.d
-       $(RM) -rf $(TARGET_DIR)/etc/sysconfig
+       $(RM) $(TARGET_DIR)/etc/rc.d/init.d/auditd
+       $(RM) $(TARGET_DIR)/etc/sysconfig/auditd
 endef
 AUDIT_POST_INSTALL_TARGET_HOOKS += AUDIT_INSTALL_CLEANUP