package/tvheadend: add option to enable descrambler support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 3 Apr 2021 15:22:34 +0000 (17:22 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 Apr 2021 12:22:24 +0000 (14:22 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[yann.morin.1998@free.fr: one option per-commit]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/tvheadend/Config.in
package/tvheadend/tvheadend.mk

index 909d955c0227ee54098c031e442b14e25dff4ddb..414892cd9e7da09e9907876a5034d8e5422849e4 100644 (file)
@@ -28,6 +28,12 @@ config BR2_PACKAGE_TVHEADEND
 
 if BR2_PACKAGE_TVHEADEND
 
+config BR2_PACKAGE_TVHEADEND_DESCRAMBLER
+       bool "descrambler support"
+       default y
+       help
+         Enable support for various descrambler modules.
+
 config BR2_PACKAGE_TVHEADEND_TRANSCODING
        bool "transcoding support"
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
index 114142bfa9f23cb514ad9217c0b06c0ee77ff21b..4043d73386ac69cf16e535c5f489358263d7d70f 100644 (file)
@@ -63,6 +63,22 @@ TVHEADEND_CONF_OPTS += \
        --disable-libx265
 endif
 
+ifeq ($(BR2_PACKAGE_TVHEADEND_DESCRAMBLER),y)
+TVHEADEND_CONF_OPTS += \
+       --enable-cardclient \
+       --enable-cwc \
+       --enable-cccam \
+       --enable-capmt \
+       --enable-constcw
+else
+TVHEADEND_CONF_OPTS += \
+       --disable-cardclient \
+       --disable-cwc \
+       --disable-cccam \
+       --disable-capmt \
+       --disable-constcw
+endif
+
 ifeq ($(BR2_PACKAGE_LIBDVBCSA),y)
 TVHEADEND_DEPENDENCIES += libdvbcsa
 TVHEADEND_CONF_OPTS += --enable-tvhcsa