package: add lesstif
authorThierry Bultel <thierry.bultel@wanadoo.fr>
Tue, 24 Sep 2013 15:45:52 +0000 (17:45 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Oct 2013 21:25:45 +0000 (23:25 +0200)
This is a quite old thing, latest version is from 2009
but it is useful to applications based on xmotif.
It has been tested with buildroot on ARM/iMX6.

[Peter: pass --no-recursion to not error out in test/configure]
Signed-off-by Thierry Bultel <thierry.bultel@wanadoo.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/lesstif/Config.in [new file with mode: 0644]
package/lesstif/lesstif.mk [new file with mode: 0644]

index da10a2363f4afcd3d6a3c0e0f30b8f9eeee1dd92..9aa9d8117a9c079924633662d0f861a6e2b994b5 100644 (file)
@@ -500,6 +500,7 @@ source "package/harfbuzz/Config.in"
 source "package/imlib2/Config.in"
 source "package/jpeg/Config.in"
 source "package/lcms2/Config.in"
+source "package/lesstif/Config.in"
 source "package/libart/Config.in"
 source "package/libdmtx/Config.in"
 source "package/libdrm/Config.in"
diff --git a/package/lesstif/Config.in b/package/lesstif/Config.in
new file mode 100644 (file)
index 0000000..3a999ea
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LESSTIF
+       bool "lesstif"
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXT
+       select BR2_PACKAGE_XLIB_LIBXEXT
+       select BR2_PACKAGE_FREETYPE
+       help
+         lesstif is the Hungry Programmers' version of OSF/Motif
+
+         http://lesstif.sourceforge.net/
diff --git a/package/lesstif/lesstif.mk b/package/lesstif/lesstif.mk
new file mode 100644 (file)
index 0000000..5115107
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# lesstif
+#
+################################################################################
+LESSTIF_VERSION = 0.95.2
+LESSTIF_SOURCE  = lesstif-$(LESSTIF_VERSION).tar.bz2
+LESSTIF_SITE    = http://downloads.sourceforge.net/project/lesstif/lesstif/$(LESSTIF_VERSION)
+LESSTIF_INSTALL_STAGING = YES
+LESSTIF_DEPENDENCIES = \
+       xlib_libXt \
+       xlib_libXext \
+       freetype
+
+LESSTIF_CONF_OPT = \
+       --with-gnu-ld \
+       --with-freetype-config=$(STAGING_DIR)/usr/bin/freetype-config \
+       --enable-debug=no \
+       --enable-production=yes \
+       --enable-build-tests=no \
+       --no-recursion
+
+# Reduces the buggy makefile to the smallest possible (and working) thing
+define LESSTIF_NOMAN2HTML
+       echo "all:"     > $(@D)/doc/Makefile
+       echo ""                 >> $(@D)/doc/Makefile
+       echo "install:" >> $(@D)/doc/Makefile
+       echo ""                 >> $(@D)/doc/Makefile
+       echo "clean:"   >> $(@D)/doc/Makefile
+endef
+
+# Prevents to copy ac_find_motif.m4 on target, it would else
+# be created at $(TARGET_DIR)/$(TOPDIR)/output/host/usr/share/aclocal/ac_find_motif.m4
+define LESSTIF_FIXACLOCAL
+       sed -i -e "/install-data-am: install-aclocalDATA/d" $(@D)/scripts/autoconf/Makefile
+endef
+
+LESSTIF_POST_CONFIGURE_HOOKS += LESSTIF_NOMAN2HTML
+LESSTIF_POST_CONFIGURE_HOOKS += LESSTIF_FIXACLOCAL
+
+$(eval $(autotools-package))