evtest: bump version to 1.31
authorPeter Seiderer <ps.report@gmx.net>
Tue, 22 Apr 2014 22:12:23 +0000 (00:12 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 May 2014 20:56:31 +0000 (22:56 +0200)
- update version to 1.31
- correct license to GPLv2+
- change download url to official repository
- remove evtest-capture support (dropped since 1.31)
- change broken project URL to official repository

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/evtest/Config.in
package/evtest/evtest.mk

index 1eb298522e69dd32657b834512f118f6e36e1cc9..00661dbc7dde8e1b8dddc7e5ee8be2a9dae14039 100644 (file)
@@ -101,6 +101,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.05"
 
+config BR2_PACKAGE_EVTEST_CAPTURE
+       bool "evtest-capture support removed (dropped since evtest 1.31)"
+       select BR2_LEGACY
+       help
+         Support for evtest-capture has been removed (dropped from
+         evtest package since version 1.31), use evemu package
+         instead.
+
 config BR2_KERNEL_HEADERS_3_6
        bool "kernel headers version 3.6.x are no longer supported"
        select BR2_KERNEL_HEADERS_3_8
index 77821c4c9e7a17d61a18b7c938e526c66c8fbc0e..1087217ee4c9f9bb04c85c5eaae0208326694e3c 100644 (file)
@@ -6,16 +6,4 @@ config BR2_PACKAGE_EVTEST
          device. It then monitors the device and displays all the
          events layer events generated.
 
-         http://www.freedesktop.org/wiki/Evtest
-
-if BR2_PACKAGE_EVTEST
-
-config BR2_PACKAGE_EVTEST_CAPTURE
-       bool "evtest-capture"
-       select BR2_PACKAGE_LIBXML2
-       help
-         evtest-capture captures the information and events from the
-         input device specified on the command line and writes it to
-         the xml file given.
-
-endif
+         http://cgit.freedesktop.org/evtest
index 2a875539cb2b4942b8384f9c658469ad6d417b58..23dd49574acc369b39378962828aea9c62267405 100644 (file)
@@ -4,25 +4,13 @@
 #
 ################################################################################
 
-EVTEST_VERSION = 1.30
-EVTEST_SOURCE = evtest-$(EVTEST_VERSION).tar.bz2
-# no official upstream tarball
-EVTEST_SITE = http://pkgs.fedoraproject.org/repo/pkgs/evtest/evtest-1.30.tar.bz2/27c0902839babfd07136f232c63c895c/
-EVTEST_LICENSE = GPLv2
+EVTEST_VERSION = 1.31
+EVTEST_SOURCE = evtest-$(EVTEST_VERSION).tar.gz
+EVTEST_SITE = http://cgit.freedesktop.org/evtest/snapshot
+EVTEST_LICENSE = GPLv2+
 EVTEST_LICENSE_FILES = COPYING
 EVTEST_DEPENDENCIES = host-pkgconf
-
-ifeq ($(BR2_PACKAGE_EVTEST_CAPTURE),y)
-EVTEST_DEPENDENCIES += libxml2
-else
-# evtest-capture will unconditionally be built/installed if libxml2 is present
-define EVTEST_REMOVE_EVTEST_CAPTURE
-       rm -rf $(TARGET_DIR)/usr/bin/evtest-capture \
-              $(TARGET_DIR)/usr/share/evtest \
-              $(TARGET_DIR)/usr/share/man/man1/evtest-capture.1
-endef
-
-EVTEST_POST_INSTALL_TARGET_HOOKS += EVTEST_REMOVE_EVTEST_CAPTURE
-endif
+# needed because source package contains no generated files
+EVTEST_AUTORECONF = YES
 
 $(eval $(autotools-package))