linenoise: patch was merged on upstream
authorFrancois Perrad <fperrad@gmail.com>
Tue, 19 Feb 2013 22:29:00 +0000 (22:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 22 Feb 2013 22:27:10 +0000 (23:27 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/linenoise/linenoise-get-columns.patch [deleted file]
package/linenoise/linenoise.mk

diff --git a/package/linenoise/linenoise-get-columns.patch b/package/linenoise/linenoise-get-columns.patch
deleted file mode 100644 (file)
index 4fb9e40..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-returns the default value (80) when a real value is not available
-(0 is not an acceptable value for COLUMNS, the width of the screen).
-
-see pull request on upstream : http://github.com/antirez/linenoise/pull/31
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/linenoise.c
-===================================================================
---- a/linenoise.c
-+++ b/linenoise.c
-@@ -182,7 +182,7 @@
- static int getColumns(void) {
-     struct winsize ws;
--    if (ioctl(1, TIOCGWINSZ, &ws) == -1) return 80;
-+    if (ioctl(1, TIOCGWINSZ, &ws) == -1 || ws.ws_col == 0) return 80;
-     return ws.ws_col;
- }
index 343a1075693269ae84ba1c157ba6162f0d25411a..fb739602a2524ee4846fd531d19c0e0b0353d311 100644 (file)
@@ -3,7 +3,7 @@
 # linenoise
 #
 #############################################################
-LINENOISE_VERSION = g8c9b481
+LINENOISE_VERSION = g27a3b4d
 LINENOISE_SITE = http://github.com/antirez/linenoise/tarball/master
 LINENOISE_LICENSE = BSD-2c
 LINENOISE_INSTALL_STAGING = YES