vmtouch: new package
authorBrandon Maier <brandon.maier@rockwellcollins.com>
Fri, 16 Nov 2018 15:52:53 +0000 (09:52 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Nov 2018 21:18:59 +0000 (22:18 +0100)
Signed-off-by: Brandon Maier <brandon.maier@rockwellcollins.com>
Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/vmtouch/Config.in [new file with mode: 0644]
package/vmtouch/vmtouch.hash [new file with mode: 0644]
package/vmtouch/vmtouch.mk [new file with mode: 0644]

index f4d98d9b0b14038f2d426650b2333dc0b3e8dee2..ff95f6aba28912a27b7a3666f6517ee025b28f36 100644 (file)
@@ -403,6 +403,9 @@ N:  Bogdan Radulescu <bogdan@nimblex.net>
 F:     package/iftop/
 F:     package/ncdu/
 
+N:     Brandon Maier <brandon.maier@rockwellcollins.com>
+F:     package/vmtouch/
+
 N:     Brock Williams <brock@cottonwoodcomputer.com>
 F:     package/pdmenu/
 
index 5a5d8403919e2fc23efb86f8842ab3d9728cde8a..6fa09bab32aa9f53dcf80dff49834ffc28974516 100644 (file)
@@ -131,6 +131,7 @@ menu "Debugging, profiling and benchmark"
        source "package/trinity/Config.in"
        source "package/uclibc-ng-test/Config.in"
        source "package/valgrind/Config.in"
+       source "package/vmtouch/Config.in"
        source "package/whetstone/Config.in"
 endmenu
 
diff --git a/package/vmtouch/Config.in b/package/vmtouch/Config.in
new file mode 100644 (file)
index 0000000..daae03a
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_VMTOUCH
+       bool "vmtouch"
+       depends on BR2_USE_MMU # fork()
+       help
+         vmtouch is a tool for learning about and controlling
+         the file system cache of unix and unix-like systems. It
+         can discover which files the OS is caching, tell the OS
+         to cache or evict some files or regions of files, lock
+         files into memory so the OS won't evict them, and more.
+
+         https://hoytech.com/vmtouch/
diff --git a/package/vmtouch/vmtouch.hash b/package/vmtouch/vmtouch.hash
new file mode 100644 (file)
index 0000000..2b98891
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally computed
+sha256 d57b7b3ae1146c4516429ab7d6db6f2122401db814ddd9cdaad10980e9c8428c  vmtouch-v1.3.1.tar.gz
+
+# Hash for license files:
+sha256 13258709ed29c17394e0a3ba8c8b9360af35b85231db514f11a0ba385cecd08e  LICENSE
diff --git a/package/vmtouch/vmtouch.mk b/package/vmtouch/vmtouch.mk
new file mode 100644 (file)
index 0000000..856835a
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# vmtouch
+#
+################################################################################
+
+VMTOUCH_VERSION = v1.3.1
+VMTOUCH_SITE = $(call github,hoytech,vmtouch,$(VMTOUCH_VERSION))
+VMTOUCH_LICENSE = BSD-3-Clause
+VMTOUCH_LICENSE_FILES = LICENSE
+
+define VMTOUCH_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define VMTOUCH_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) install \
+               DESTDIR=$(TARGET_DIR) PREFIX=/usr
+endef
+
+$(eval $(generic-package))