qemu: fix host virtfs option
authorVincent Stehlé <vincent.stehle@arm.com>
Thu, 1 Aug 2019 17:09:24 +0000 (19:09 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 1 Aug 2019 17:56:03 +0000 (19:56 +0200)
Fix the build of host-qemu with virtfs enabled: fix a typo in makefile
conditional and add a dependency on host-libcap as that is a dependency of
virtfs support:

    if test "$virtfs" != no && test "$cap" = yes && test "$attr" = yes ; then
      virtfs=yes

The virtfs configuration option was added by commit e0f49e648401
("package/qemu: add option to enable virtual filesystem in host qemu").

Signed-off-by: Vincent Stehlé <vincent.stehle@arm.com>
Cc: Etienne Carriere <etienne.carriere@linaro.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qemu/qemu.mk

index 73e0778d73df4a11109b1bb3c67efaad4917b21f..2c11f64ad04d512568ba7d5308f2f5c5762e61e3 100644 (file)
@@ -271,8 +271,11 @@ HOST_QEMU_OPTS += --enable-vde
 HOST_QEMU_DEPENDENCIES += host-vde2
 endif
 
-ifdef ($(BR2_PACKAGE_HOST_QEMU_VIRTFS),y)
+ifeq ($(BR2_PACKAGE_HOST_QEMU_VIRTFS),y)
 HOST_QEMU_OPTS += --enable-virtfs
+HOST_QEMU_DEPENDENCIES += host-libcap
+else
+HOST_QEMU_OPTS += --disable-virtfs
 endif
 
 # Override CPP, as it expects to be able to call it like it'd