btrfs-progs: bump version to 4.10
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 10 Mar 2017 15:05:44 +0000 (15:05 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 10 Mar 2017 21:04:24 +0000 (22:04 +0100)
Rebase patch for this new release.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/btrfs-progs/0001-Makefile-install-static-library-and-headers-in-insta.patch [new file with mode: 0644]
package/btrfs-progs/0001-Makefile.in-install-static-library-and-headers-in-in.patch [deleted file]
package/btrfs-progs/btrfs-progs.hash
package/btrfs-progs/btrfs-progs.mk

diff --git a/package/btrfs-progs/0001-Makefile-install-static-library-and-headers-in-insta.patch b/package/btrfs-progs/0001-Makefile-install-static-library-and-headers-in-insta.patch
new file mode 100644 (file)
index 0000000..ba65ac4
--- /dev/null
@@ -0,0 +1,49 @@
+From ff93866eb119cedb791894814780c0e44db35715 Mon Sep 17 00:00:00 2001
+From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+Date: Fri, 10 Mar 2017 14:56:17 +0000
+Subject: [PATCH] Makefile: install static library and headers in
+ install-static
+
+Currently, the install-static target only installs the statically
+compiled tools. However, some programs outside of btrfs-progs (for
+example docker) link with the btrfs libraries. If such programs want to
+link statically against the btrfs-progs library, then this library
+should be installed by "install-static". Indeed, "make install" cannot
+be used if the support for shared library is not enabled.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+[Gustavo: Rebase for btrfs-progs 4.7.2]
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+[Vincent: Rebase for btrfs-progs 4.10]
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+---
+ Makefile | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 67fbc48..d9e34be 100644
+--- a/Makefile
++++ b/Makefile
+@@ -308,7 +308,7 @@ test: test-fsck test-mkfs test-convert test-misc test-fuzz test-cli
+ # NOTE: For static compiles, you need to have all the required libs
+ #     static equivalent available
+ #
+-static: $(progs_static)
++static: $(progs_static) $(libs_static)
+ version.h: version.sh version.h.in configure.ac
+       @echo "    [SH]     $@"
+@@ -537,6 +537,10 @@ install-static: $(progs_static) $(INSTALLDIRS)
+       $(INSTALL) $(progs_static) $(DESTDIR)$(bindir)
+       # btrfsck is a link to btrfs in the src tree, make it so for installed file as well
+       $(LN_S) -f btrfs.static $(DESTDIR)$(bindir)/btrfsck.static
++      $(INSTALL) -m755 -d $(DESTDIR)$(libdir)
++      $(INSTALL) $(libs_static) $(DESTDIR)$(libdir)
++      $(INSTALL) -m755 -d $(DESTDIR)$(incdir)
++      $(INSTALL) -m644 $(headers) $(DESTDIR)$(incdir)
+ $(INSTALLDIRS):
+       @echo "Making install in $(patsubst install-%,%,$@)"
+-- 
+2.10.2
+
diff --git a/package/btrfs-progs/0001-Makefile.in-install-static-library-and-headers-in-in.patch b/package/btrfs-progs/0001-Makefile.in-install-static-library-and-headers-in-in.patch
deleted file mode 100644 (file)
index d861dfc..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From 2c2c2d992c3b298793983317588f73cf41675652 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Wed, 27 Jul 2016 22:49:58 +0200
-Subject: [PATCH] Makefile.in: install static library and headers in
- install-static
-
-Currently, the install-static target only installs the statically
-compiled tools. However, some programs outside of btrfs-progs (for
-example docker) link with the btrfs libraries. If such programs want
-to link statically against the btrfs-progs library, then this library
-should be installed by "install-static". Indeed, "make install" cannot
-be used if the support for shared library is not enabled.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-[Gustavo: Rebase for btrfs-progs 4.7.2]
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
- Makefile.in | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index 19697ff..5870a58 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -219,7 +219,7 @@ test: test-fsck test-mkfs test-convert test-misc test-fuzz
- # NOTE: For static compiles, you need to have all the required libs
- #     static equivalent available
- #
--static: $(progs_static)
-+static: $(progs_static) $(libs_static)
- version.h: version.sh version.h.in configure.ac
-       @echo "    [SH]     $@"
-@@ -384,6 +384,10 @@ install-static: $(progs_static) $(INSTALLDIRS)
-       done
-       # btrfsck is a link to btrfs in the src tree, make it so for installed file as well
-       $(LN_S) -f btrfs.static $(DESTDIR)$(bindir)/btrfsck.static
-+      $(INSTALL) -m755 -d $(DESTDIR)$(libdir)
-+      $(INSTALL) $(libs_static) $(DESTDIR)$(libdir)
-+      $(INSTALL) -m755 -d $(DESTDIR)$(incdir)
-+      $(INSTALL) -m644 $(headers) $(DESTDIR)$(incdir)
- $(INSTALLDIRS):
-       @echo "Making install in $(patsubst install-%,%,$@)"
--- 
-2.7.3
-
index f9809289b0a075b2ce8413497fcc413e79dabc21..3d0f2db54380bf76275f3bfcbe8bdf86b76f6ad4 100644 (file)
@@ -1,2 +1,2 @@
 # From https://www.kernel.org/pub/linux/kernel/people/kdave/btrfs-progs/sha256sums.asc
-sha256 464a9bfd2b5eda76b0246ee0a4043f4de8d17c10312bc8b84abc5fbf9317fede  btrfs-progs-v4.9.1.tar.xz
+sha256 44cbcca39af70dad5a8bf0343fca48f7aaa1aeae0eefac5003688452b3155cda  btrfs-progs-v4.10.tar.xz
index f73397ca8e713807aa67c11fc868a03417ccac4c..5448bef32692439eb0b0e142ca4a814e1d627a02 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BTRFS_PROGS_VERSION = 4.9.1
+BTRFS_PROGS_VERSION = 4.10
 BTRFS_PROGS_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/people/kdave/btrfs-progs
 BTRFS_PROGS_SOURCE = btrfs-progs-v$(BTRFS_PROGS_VERSION).tar.xz
 BTRFS_PROGS_DEPENDENCIES = host-pkgconf e2fsprogs lzo util-linux zlib