pcre2: new package
authorNaoki Matsumoto <n-matsumoto@melcoinc.co.jp>
Fri, 7 Jul 2017 03:45:16 +0000 (03:45 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Jul 2017 16:13:39 +0000 (18:13 +0200)
Signed-off-by: Naoki Matsumoto <n-matsumoto@melcoinc.co.jp>
Signed-off-by: Brent Sink <brents_3@hotmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Thomas:
 - reassign authorship to Naoki Matsumoto
 - add entry to DEVELOPERS file
 - fix broken patch
 - add comment about where the PGP signature was coming from]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/pcre2/Config.in [new file with mode: 0644]
package/pcre2/pcre2.hash [new file with mode: 0644]
package/pcre2/pcre2.mk [new file with mode: 0644]

index c9975008424c3927ea5c0dfe3cfbc3b171184644..1ec405a5705880c67dcd84951bc9207fbf2ee830 100644 (file)
@@ -1239,6 +1239,9 @@ N:        Murat Demirten <mdemirten@yh.com.tr>
 F:     package/jpeg-turbo/
 F:     package/libgeotiff/
 
+N:     Naoki Matsumoto <n-matsumoto@melcoinc.co.jp>
+F:     package/pcre2/
+
 N:     Nathan Lynch <ntl@pobox.com>
 F:     package/chrony/
 
index e675bca09b6178b33328ac75043a0eaddadf82bf..db943dff1f64ce72772f10c6cdda561e2d419f92 100644 (file)
@@ -1494,6 +1494,7 @@ menu "Text and terminal handling"
        source "package/ncurses/Config.in"
        source "package/newt/Config.in"
        source "package/pcre/Config.in"
+       source "package/pcre2/Config.in"
        source "package/popt/Config.in"
        source "package/readline/Config.in"
        source "package/slang/Config.in"
diff --git a/package/pcre2/Config.in b/package/pcre2/Config.in
new file mode 100644 (file)
index 0000000..b49d306
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_PCRE2
+       bool "pcre2"
+       help
+         Perl Compatible Regular Expressions. By default, only the
+         8-bits libpcre2 is built. To get the 16-bits and/or 32-bits
+         variants libpcre2-16/libpcre2-32, use the package sub-options.
+
+         http://www.pcre.org/
+
+if BR2_PACKAGE_PCRE2
+
+config BR2_PACKAGE_PCRE2_16
+       bool "16-bit pcre2"
+       help
+         This option builds the 16-bits pcre2 library, i.e 'libpcre2-16'
+
+config BR2_PACKAGE_PCRE2_32
+       bool "32-bit pcre2"
+       help
+         This option builds the 32-bits pcre2 library, i.e 'libpcre2-32'
+
+endif
diff --git a/package/pcre2/pcre2.hash b/package/pcre2/pcre2.hash
new file mode 100644 (file)
index 0000000..97a5d5e
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated after checking pgp signature at https://ftp.pcre.org/pub/pcre/pcre2-10.23.tar.bz2.sig
+sha256 dfc79b918771f02d33968bd34a749ad7487fa1014aeb787fad29dd392b78c56e        pcre2-10.23.tar.bz2
diff --git a/package/pcre2/pcre2.mk b/package/pcre2/pcre2.mk
new file mode 100644 (file)
index 0000000..5b7a163
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# pcre2
+#
+################################################################################
+
+PCRE2_VERSION = 10.23
+PCRE2_SITE = https://ftp.pcre.org/pub/pcre
+PCRE2_SOURCE = pcre2-$(PCRE2_VERSION).tar.bz2
+PCRE2_LICENSE = BSD-3-Clause
+PCRE2_LICENSE_FILES = LICENCE
+PCRE2_INSTALL_STAGING = YES
+PCRE2_CONFIG_SCRIPTS = pcre2-config
+
+PCRE2_CONF_OPTS += --enable-pcre2-8
+PCRE2_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE2_16),--enable-pcre2-16,--disable-pcre2-16)
+PCRE2_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE2_32),--enable-pcre2-32,--disable-pcre2-32)
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))