package/yajl: add sequence number in patch names
authorSamuel Martin <s.martin49@gmail.com>
Sun, 31 Aug 2014 19:55:15 +0000 (21:55 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 Aug 2014 20:26:18 +0000 (22:26 +0200)
Also remove the package version from the patch names.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/yajl/yajl-0001-math-link.patch [new file with mode: 0644]
package/yajl/yajl-2.0.4-math-link.patch [deleted file]

diff --git a/package/yajl/yajl-0001-math-link.patch b/package/yajl/yajl-0001-math-link.patch
new file mode 100644 (file)
index 0000000..355a248
--- /dev/null
@@ -0,0 +1,24 @@
+[PATCH] fix json_reformat linking on uClibc
+
+json_reformat calls yajl_gen_* functions, which internally use isnan() /
+isinf(). On Glibc, these are provided by libc, but on uClibc you need to
+link with -lm (like the spec says), so ensure we do so.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ reformatter/CMakeLists.txt |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: yajl-2.0.2/reformatter/CMakeLists.txt
+===================================================================
+--- yajl-2.0.2.orig/reformatter/CMakeLists.txt
++++ yajl-2.0.2/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
diff --git a/package/yajl/yajl-2.0.4-math-link.patch b/package/yajl/yajl-2.0.4-math-link.patch
deleted file mode 100644 (file)
index 355a248..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-[PATCH] fix json_reformat linking on uClibc
-
-json_reformat calls yajl_gen_* functions, which internally use isnan() /
-isinf(). On Glibc, these are provided by libc, but on uClibc you need to
-link with -lm (like the spec says), so ensure we do so.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- reformatter/CMakeLists.txt |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: yajl-2.0.2/reformatter/CMakeLists.txt
-===================================================================
---- yajl-2.0.2.orig/reformatter/CMakeLists.txt
-+++ yajl-2.0.2/reformatter/CMakeLists.txt
-@@ -26,7 +26,7 @@
- ADD_EXECUTABLE(json_reformat ${SRCS})
--TARGET_LINK_LIBRARIES(json_reformat yajl_s)
-+TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
- # copy the binary into the output directory
- GET_TARGET_PROPERTY(binPath json_reformat LOCATION)