package/go: add double quotes around TARGET_CC/TARGET_CXX
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 May 2016 19:06:26 +0000 (21:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 May 2016 19:06:55 +0000 (21:06 +0200)
Using double quotes around TARGET_CC/TARGET_CXX is mandatory, since
they are composed of several words when ccache support is enabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/go/go.mk

index 98615aaeaf5e9ac113a60d4d84a5c1097eb95aa8..a1d6cf9df2081d0e8119cb3349e53b719aa1d05a 100644 (file)
@@ -40,8 +40,8 @@ HOST_GO_TOOLDIR = $(HOST_GO_ROOT)/pkg/tool/linux_$(GO_GOARCH)
 HOST_GO_TARGET_ENV = \
        GOARCH=$(GO_GOARCH) \
        GOROOT="$(HOST_GO_ROOT)" \
-       CC=$(TARGET_CC) \
-       CXX=$(TARGET_CXX) \
+       CC="$(TARGET_CC)" \
+       CXX="$(TARGET_CXX)" \
        GOTOOLDIR="$(HOST_GO_TOOLDIR)"
 
 # The go compiler's cgo support uses threads.  If BR2_TOOLCHAIN_HAS_THREADS is
@@ -74,8 +74,8 @@ HOST_GO_MAKE_ENV = \
        CC=$(HOSTCC_NOCCACHE)
 
 HOST_GO_TARGET_CC = \
-       CC_FOR_TARGET=$(TARGET_CC) \
-       CXX_FOR_TARGET=$(TARGET_CXX)
+       CC_FOR_TARGET="$(TARGET_CC)" \
+       CXX_FOR_TARGET="$(TARGET_CXX)"
 
 HOST_GO_HOST_CC = \
        CC_FOR_TARGET=$(HOSTCC_NOCCACHE) \