pure-ftpd: Added pure-ftpd quotas config option
authorBryce Ferguson <bryce.ferguson@rockwellcollins.com>
Wed, 18 Jan 2017 18:58:51 +0000 (12:58 -0600)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jan 2017 09:20:46 +0000 (22:20 +1300)
Added the pure-ftp quotas option.  When selected, the --with-quotas
compiler option is passed which enables the quota feature

Note that this increases the size of the pure-ftpd executable by
about 20%.

Signed-off-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pure-ftpd/Config.in
package/pure-ftpd/pure-ftpd.mk

index 85fdef30eb73f7cca5a74feed748c2c365310dd9..57b78d1ae6d84f4d90d770076581d54623aab310 100644 (file)
@@ -20,4 +20,12 @@ config BR2_PACKAGE_PURE_FTPD_FTPWHO
          client sessions.  Only the system administrator may run this.  Output
          can be text (default), HTML, XML data and parser-optimized.
 
+config BR2_PACKAGE_PURE_FTPD_QUOTAS
+       bool "quotas"
+       help
+         Enable virtual quotas. With virtual quotas, restrictions can
+         be placed on the maximum number of files a user can store in
+         his account. In addition, restrictions can also be placed
+         on the total size.
+
 endif
index 80e432af56f5b6a2a9989326cb38fc6d34b6287f..95e7065580fba9221c5bac553c1a2f35713833b3 100644 (file)
@@ -49,4 +49,8 @@ ifeq ($(BR2_PACKAGE_PURE_FTPD_FTPWHO),y)
 PURE_FTPD_CONF_OPTS += --with-ftpwho
 endif
 
+ifeq ($(BR2_PACKAGE_PURE_FTPD_QUOTAS),y)
+PURE_FTPD_CONF_OPTS += --with-quotas
+endif
+
 $(eval $(autotools-package))