package/bluez5_utils: correct systemd service install
authorMartin Bark <martin@barkynet.com>
Thu, 16 Jun 2016 17:15:38 +0000 (18:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Jun 2016 13:37:47 +0000 (15:37 +0200)
Commit d732fa4 add the BLUEZ5_UTILS_INSTALL_INIT_SYSTEMD rule, however,
it is not correct.  The [Install] section of bluetooth.service is as
follows:

 [Install]
 WantedBy=bluetooth.target
 Alias=dbus-org.bluez.service

hence there are currently two mistakes:
 1) bluetooth.service is wanted by bluetooth.target not multi-user.target
 2) dbus-org.bluez.service is a missing alias to bluetooth.service

This commit fixes both these issues.

Signed-off-by: Martin Bark <martin@barkynet.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bluez5_utils/bluez5_utils.mk

index ddc8c452eea60d2bee0c8450b7b8bed80470581d..49cc7c21760d661eb68f51382a24da0865e972da 100644 (file)
@@ -77,9 +77,11 @@ BLUEZ5_UTILS_CONF_OPTS += --disable-systemd
 endif
 
 define BLUEZ5_UTILS_INSTALL_INIT_SYSTEMD
-       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/bluetooth.target.wants
        ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/bluetooth.service
+               $(TARGET_DIR)/etc/systemd/system/bluetooth.target.wants/bluetooth.service
+       ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
+               $(TARGET_DIR)/etc/systemd/system/dbus-org.bluez.service
 endef
 
 $(eval $(autotools-package))