package/pound: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 5 Feb 2016 22:43:12 +0000 (23:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 22:00:16 +0000 (23:00 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: pass --with-owner/--with-group instead of SEDing the
Makefile.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/pound/Config.in [new file with mode: 0644]
package/pound/pound.hash [new file with mode: 0644]
package/pound/pound.mk [new file with mode: 0644]

index c0b3b177e98c5858609b69c6ea29b21b056edc95..23fd62c07a9453be9d0b7620c28b30b8851eb788 100644 (file)
@@ -1448,6 +1448,7 @@ endif
        source "package/p910nd/Config.in"
        source "package/phidgetwebservice/Config.in"
        source "package/portmap/Config.in"
+       source "package/pound/Config.in"
        source "package/pppd/Config.in"
        source "package/pptp-linux/Config.in"
        source "package/privoxy/Config.in"
diff --git a/package/pound/Config.in b/package/pound/Config.in
new file mode 100644 (file)
index 0000000..91c29ea
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_POUND
+       bool "pound"
+       depends on !BR2_STATIC_LIBS
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       select BR2_PACKAGE_OPENSSL
+       help
+         The Pound program is a reverse proxy, load balancer and HTTPS
+         front-end for Web server(s). Pound was developed to enable
+         distributing the load among several Web-servers and to allow
+         for a convenient SSL wrapper for those Web servers that do not
+         offer it natively.
+
+         http://www.apsis.ch/pound
+
+comment "pound needs a toolchain w/ dynamic library, threads"
+       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
diff --git a/package/pound/pound.hash b/package/pound/pound.hash
new file mode 100644 (file)
index 0000000..6908b90
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 cdfbf5a7e8dc8fbbe0d6c1e83cd3bd3f2472160aac65684bb01ef661c626a8e4        Pound-2.7.tgz
diff --git a/package/pound/pound.mk b/package/pound/pound.mk
new file mode 100644 (file)
index 0000000..4086642
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# pound
+#
+################################################################################
+
+POUND_VERSION = 2.7
+POUND_SITE = http://www.apsis.ch/pound
+POUND_SOURCE = Pound-$(POUND_VERSION).tgz
+POUND_LICENSE = GPLv3+
+POUND_LICENSE_FILES = GPL.txt
+POUND_DEPENDENCIES = openssl
+
+# Force owner/group to us, otherwise it will try proxy:proxy by
+# default.
+POUND_CONF_OPTS = \
+       --with-owner=$(shell id -un) \
+       --with-group=$(shell id -gn)
+
+ifeq ($(BR2_PACKAGE_PCRE),y)
+POUND_DEPENDENCIES += pcre
+endif
+
+$(eval $(autotools-package))