uclibc: disable parallel build for uClibc 0.9.31
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Mon, 30 Jun 2014 16:16:53 +0000 (20:16 +0400)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Jul 2014 13:04:04 +0000 (15:04 +0200)
This is only required for uClibc 0.9.31 and this veriosn is only used by
AVR32 so could be safely removed together with AVR32.

Even 0.9.32 builds well in parallel (at least on x86) so IMHO there's no need
in >= 0.9.33, just disable for a particular broken version.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Anton Kolesov <akolesov@synopsys.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/uclibc.mk

index 8337bb6f847f9994e267aa41b66a9ccc78d84fb4..e20f92fd0355fc02360563c3e47d70eb1efd514a 100644 (file)
@@ -481,8 +481,20 @@ define UCLIBC_BUILD_TEST_SUITE
 endef
 endif
 
+# In uClibc 0.9.31 parallel building is broken so we have to disable it
+# Fortunately uClibc 0.9.31 is only used by AVR32 and in its turn AVR32 is
+# about to be removed from buildroot.
+#
+# So as soon as AVR32 is removed please revert this patch so instead of
+# UCLIBC_MAKE normal "MAKE" is used in UCLIBC_BUILD_CMDS
+ifeq ($(BR2_UCLIBC_VERSION_0_9_31),y)
+       UCLIBC_MAKE = $(MAKE1)
+else
+       UCLIBC_MAKE = $(MAKE)
+endif
+
 define UCLIBC_BUILD_CMDS
-       $(MAKE) -C $(@D) \
+       $(UCLIBC_MAKE) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \
                PREFIX= \
                DEVEL_PREFIX=/ \