pngquant: doesn't support building with ccache
authorArnout Vandecappelle <arnout@mind.be>
Mon, 3 Jul 2017 21:43:55 +0000 (23:43 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Jul 2017 22:37:04 +0000 (00:37 +0200)
pngquant's homegrown configure script doesn't understand CC with a
space, so we can't use ccache with it. Only the host variant is
affected: for the target, we call ccache from the toolchain-wrapper so
it's transparent to the configure script.

This wasn't seen in the autobuilders since they never enable
BR2_CCACHE.

To test, use any configuration and do
make BR2_CCACHE=y host-pngquant

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pngquant/pngquant.mk

index 4a6f32fdca17d6a4ae8799a035a26b957d2e02d4..938603a21d4adc671adcb18d418d09daeb86e97c 100644 (file)
@@ -36,6 +36,7 @@ endef
 define HOST_PNGQUANT_CONFIGURE_CMDS
        (cd $(@D) && \
                $(HOST_CONFIGURE_OPTS) \
+               CC=$(HOSTCC_NOCCACHE) \
                ./configure --prefix=$(HOST_DIR)/usr \
                --without-lcms2 \
        )