lttng-tools: make the dependency on lttng-libust optional
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Feb 2012 14:48:46 +0000 (15:48 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 5 Feb 2012 10:16:33 +0000 (11:16 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lttng-tools/Config.in
package/lttng-tools/lttng-tools.mk

index cc7496605cd0f12cc8c5676ed71745b463e1b555..3040af6129b73bc915e3369d07593b8e8b150494 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_LTTNG_TOOLS
        depends on BR2_PACKAGE_LTTNG_MODULES
        select BR2_PACKAGE_LIBURCU
        select BR2_PACKAGE_POPT
-       select BR2_PACKAGE_LTTNG_LIBUST
        help
          Userspace utilities for the LTTng 2.0 tracing
          infrastructure.
@@ -17,4 +16,7 @@ config BR2_PACKAGE_LTTNG_TOOLS
          package for the target, if babeltrace on the target is
          interesting.
 
+         If userspace tracing is desired, you need to enable
+         lttng-libust.
+
          http://lttng.org
index bcf2f678f3c08c2cecda0f7b077e243b90b523a0..8e6fc1abcef12a1b50b7f05e49ffad76addf2760 100644 (file)
@@ -6,8 +6,15 @@ LTTNG_TOOLS_SOURCE  = lttng-tools-$(LTTNG_TOOLS_VERSION).tar.bz2
 # dependency. However, having the babeltrace utilities built for the
 # host is very useful, since those tools allow to convert the binary
 # trace format into an human readable format.
-LTTNG_TOOLS_DEPENDENCIES = liburcu popt host-lttng-babeltrace lttng-libust
+LTTNG_TOOLS_DEPENDENCIES = liburcu popt host-lttng-babeltrace
 
 LTTNG_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_LTTNG_LIBUST),y)
+LTTNG_TOOLS_CONF_OPT += --enable-lttng-ust
+LTTNG_TOOLS_DEPENDENCIES += lttng-libust
+else
+LTTNG_TOOLS_CONF_OPT += --disable-lttng-ust
+endif
+
 $(eval $(call AUTOTARGETS))